Browse FAQs

Will Unity Pro version 8 run on Windows XP?

Published date: 29 June 2020

Yes, Unity Pro will run on  Win XP but SP3 is required.

Was this helpful?

What can we do to improve the information ?

Can't find what you are looking for?

Reach out to our customer care team to receive information on technical support, assistance for complaints and more.