Browse FAQs

How do I reset my Wiser system password on wiserenergy.com?

Published date: 05 June 2020

Issue:
Customer has lost his username or password.  He/she would like to reset it.

Product Line:
Wiser Home Management System per-2017 US model only

Environment:
Residential customer
wiserenergy.com

Cause:
Customer lost or forgot username or password.

Resolution:
The username and password recovery can be executed by the Wiser User or by Wiser Customer Care Agent.

On Wiserenergy.com, if a sign-in attempt fails, then then the webpage will show a "Login Help" link below the Login button.  This link will take the user to a page that will allow the user to initiate a password reset.  
https://www.wiserenergy.com/getlogininfo.aspx

Wiser Customer Service can also trigger a password reset.  A new temporary password and login instructions will be emailed to the end-user.

Was this helpful?

What can we do to improve the information ?

Can't find what you are looking for?

Reach out to our customer care team to receive information on technical support, assistance for complaints and more.