Browse FAQs

SFT2841 old version(2013) does not read newly installed Sepam 20 & 80 relays.After install the new version new version has completely stopped establishing a Frontal connection with Sepam of any version. How to activate the new software version

Published date: 15 January 2021

Issue:
SFT2841 old version(2013) does not read newly installed Sepam 20 & 80 relays. It only reads series 40. To fix this, we downloaded the new software version from your website. Installed it. On first launch, it uninstalled its old version. Installed from the second launch. However, the new version has completely stopped establishing a Frontal connection with Sepam of any version. Please advise how to activate the new software version. we are using  am using a laptop with Win7.

Environment/Product line:
Sepam 20 & 80 relays

Resolution :
The problem is in the incorrectly installed Modbus device driver.
You need to manually uninstall the SFT2841 program &  uninstall Driver Manager X64 and remove Modbus Driver X64
Please restart a computer & will install new version SFT2841.
After these steps, you may need to update the Modbus Serial Driver using Windows.

 

Was this helpful?

What can we do to improve the information ?

Can't find what you are looking for?

Reach out to our customer care team to receive information on technical support, assistance for complaints and more.