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Client Nodes Cannot Connect to Server "Node name could not be registered for this connection. Check the NOM is running"
Issue
The user is able to view and modify the system using the Management Console, but when the user starts a client application (Vista, Designer, etc.), the following message appears:
'Node name could not be registered for this connection. Check the NOM is running'.
Product Line
StruxureWare Power Monitoring Expert, ION Enterprise
Environment
ION Enterprise 4.5/5.x/6.0, StruxureWare Power Monitoring 7.0, Power Monitoring Expert 7.2, Power Monitoring Expert 8
Cause
If the user defines an IP address (rather than a machine name) or the fully qualified servername rather than the short form when prompted for the primary machine during a client install, the install will complete but the following registry values will be populated incorrectly:
* NetmanMachine
* PrimaryMachine
Resolution
*Warning: This article contains information about editing the registry. Improper changes to the registry can permanently damage the operating system. Always backup the registry before making any changes.*
During a client install, the user is prompted to enter the name of the primary machine. The Installer then verifies that the Primary machine is available. If the primary machine cannot be contacted, the Installer will report an error and prompt the user to verify that the entered name is correct.
The Installer will be unable to locate the primary machine by name if the mapping of that name to an IP address is not available in either the DNS registry or in the local hosts file. Entering the primary machine's IP address (instead of the name) will allow the Install to proceed but the user will later encounter issues as described in this article.
In cases where PME/ION Enterprise server is across a public network, you will not be able to see the server by computer name. In this case, use the Enable LMHOSTS Lookup parameter in you network settings.
* Edit the LMHOSTS.SAM found in WINNT\\System32\\Drivers\\etc. Instructions are in the file.
* Go to Network and Dial-Up Connections -> Local Area Connection -> Properties.
* Open the properties for the TCP/IP protocol and go to the Advanced WINS configuration.
* Check the Enable LMHOSTS lookup and then import the LMHOSTS.SAM file.
The ION Enterprise/PME client settings should be defined according to the rules below in order to establish a connection successfully to the ION Enterprise/PME primary server:
- The NetmanMachine registry, value to the name of the primary machine to be set to the short servernam. (E.g. PMESERVER1)
- The PrimaryMachine registry, value to the name of the primary machine. (E.g. PMESERVER1.nam.gad.schneider-electric.com)
In cases where the client was installed with a full qualified server name, attempt to uninstall the client and reinstall it with the short server name.
1. You can also fix the problem by editing the client registry directly using regedit.
For example:
If during the installation of the client, PMESERVER1.nam.gad.schneider-electric.com has been entered as the Primary Server then the registry setting of NetmanMachine has to be changed from PMESERVER1.nam.gad.schneider-electric.com to PMESERVER1.
If during the installation of the client, PMESERVER1 has been entered as the Primary Server then the registry setting of PrimaryMachine needs to be changed from PMESERVER1 to PMESERVER1.nam.gad.schneider-electric.com.
2. The registry setting for IONServices\ScheduledReadMode needs to be changed to “Polling” instead of “Callback”.
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