Problema:
NetBotz: I dati del sensore scaricati nel file CSV mostrano caratteri speciali?
Linea di prodotti:
NetBotz
Ambiente:
NBRK0750
NBWL0755
Causa:
Il Netbotz consente all'utente di scaricare i CSV, principalmente il CSV dei dati del sensore di temperatura, il CSV dell'accesso al rack e il CSV degli allarmi. Quando un cliente apre un CSV scaricato da Netbotz in Excel, a volte appaiono caratteri strani.
Un esempio specifico è che i dati del sensore di temperatura, che hanno il simbolo del grado di temperatura, che viene sostituito da caratteri casuali.
Questo è un problema solo quando si apre un file in Excel.
Altre applicazioni come Numbers, leggono i dati normalmente. Questo perché Excel non riconosce automaticamente l'UTF-8, il formato dei CSV.
Pertanto, alcuni byte del file di testo vengono letti in Excel con la codifica ANSI.
Risoluzione:
Invece di fare doppio clic e aprire il file direttamente in Excel, procedete come segue:
Aprite Excel, andate su “Nuovo” e create una cartella di lavoro vuota.
Andare a “Dati” nell'applicazione Excel
Fare clic sul menu a tendina “Ottieni dati (Power Query)”.
Selezionare “Da testo (Legacy)”.
Selezionare il CSV, in questo caso il CSV dei dati del sensore di temperatura.
Viene visualizzata automaticamente la procedura guidata di importazione del testo. Selezionare l'opzione “Delimitato”.
Nella stessa schermata, fare clic sul menu a discesa “Origine file”. Selezionare “Unicode (UTF-8)”. Fare clic su Avanti
Nella colonna “Delimitatori”, deselezionare “Tab” e selezionare “Comma”.
Fare clic su “Fine”. I dati dovrebbero apparire nel foglio esistente, con la formula =$A$1.
I dati dovrebbero apparire senza caratteri strani nella codifica UTF-8.
Pubblicato per: Schneider Electric Italy



