Browse FAQs

When I launch SoMove 2.7, and press the Edit Connection / Scan button, a blank black screen appears

Published date: 20 November 2019

Issue
When I launch SoMove 2.7, particularly in Windows 7, and press the "Edit Connection / Scan" button, a blank black dialog screen appears. How do I fix this?

The issue appears as follows. Note the black boxes in the "Scan Result" and in the "Take Survey" banner:


Normally, there should be no black boxes as in this screenshot:


Product Line
SoMove

Environment
Drive DTM configuration software running in Windows 7

Cause
This is caused by Windows Presentation Foundation (WPF) issues in Windows 7. The video driver overwrites the data in the font cache that is stored in memory resulting in misdrawn objects.

Resolution
Follow these steps:
  1. Make sure, the any USB cables related to Schneider Electric devices is unplugged (mouse dongles are fine)
  2. Uninstall SoMove using the MSFixit package "MicrosoftProgram_Install_and_Uninstall.meta.diagcab" from Microsoft:
    https://support.microsoft.com/en-ca/help/17588/windows-fix-problems-that-block-programs-being-installed-or-removed
  3. From Windows Control Panel/Programs and Features, uninstall: CANopenCommunicationDTMLibrary
  4. From Windows Control Panel/Programs and Features, uninstall: SchneiderElectricModbusCommunicationDTMLibrary
  5. Go to C:\ProgramData\Schneider Electric\ and delete the SoMove folder (ProgramData is a hidden folder. To reveal it, use your Windows File Exporer Folder Options)
  6. Update your PC’s graphic card drivers.
  7. Apply the instructions in: “SoMove - System.Windows.Media.FontFamily.pdf”
  8. Install SoMove once again.

Was this helpful?

What can we do to improve the information ?

Can't find what you are looking for?

Reach out to our customer care team to receive information on technical support, assistance for complaints and more.