Archive database upgrade fails in database manager
Issue:
ION_Data Archive database upgrade fails in PME using database manager
Product Line:
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024
Environment:
Database Manager
Cause:
The user has an ION_Data archive that was created from previous versions of the software and may have been copied and moved to a location on an external or network drive. Before this archive can be used in PME it must be attached to SQL server with Database Manager and upgraded.
Resolution:
Attaching the ION_Data archive database may fail with the following error message: Attached database failed for server .
When you click OK to the error dialog box and try attaching the second time, a new error will reveal more information that will be helpful.
The file permissions changed when the archive database was copied or moved to different locations. To resolve this issue change the permissions to allow "Full control" for the user.
- Right-click on the archive database file (.mdf) and select ->Properties->Security Tab -> Edit button.
- Click the add button and add the current user
- Select the new user and check the box under Allow for the row "Full control"
Repeat this procedure for the archive Log file (.ldf).
Recommendation:
If you are using an older version of PME, consider upgrading to the latest version for improved protocol support and security. For assistance with integration or upgrades, contact Schneider Electric Technical Support at: pmo-psup@se.com