Manually Uninstalling PowerChute Business Edition Due To Incomplete Removal Or "Maintenance Successful" Error When Reinstalling The Software
Published date:
29 January 2019
Issue:
Manually Uninstalling PowerChute Business Edition Due To Incomplete Removal Or "Maintenance Successful" Error When Reinstalling The Software
Product Line:
PowerChute Business Edition (PCBE)
Environment:
Windows OS
Cause:
Incomplete Removal Or "Maintenance Successful" Error When Reinstalling The Software
Resolution:
Remove PowerChute Business Edition, by deleting the folders and registry keys created by the install.
Warning: Using the Registry Editor incorrectly can cause serious system wide problems that may require you to reinstall Windows to correct them. Schneider Electric and Microsoft can not guarantee that any problems resulting from the use of Registry Editor can be solved. Use this tool at your own risk.Schneider Electric is not responsible for any consequence caused by editing of the system registry.
1. Make sure the APC PBE Agent and APC PBE Server services are stopped if they exist.
2. Delete the following folders through Windows Explorer or My Computer:
Agent: c:\Program Files\APC\PowerChute Business Edition\agent (or whatever the install path was) c:\Program Files\InstallShield Installation Information\{BCE9F441-9027-4911-82E0-5FB28057897D}
3. Go to the start menu, then run, and type regedit or regedit32.
4. Find and delete the following keys. Note… some keys may require a change of security. Keys such as KEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\LEGACY_APCPBESERVER may error when attempting to delete them.
To change the security, select the key to be deleted and go to the security menu option and choose permissions. Make sure you have full control access. You can set this access to everyone as it will be deleted and permissions will no longer be an issue.