Issue:
When upgrading to Power Monitoring Expert 7.2.x or PME 8.x, the installer fails on the 'Verify Database' step, with the following message:
"The ION_Network table was not upgraded successfully"
Product Line:
Power Monitoring Expert
StruxureWare Power Monitoring 7.0.x
StruxureWare Power Monitoring 8.x
ION Enterprise
Environment:
Product Installer
Cause:
This problem can occur if the ION_Network database comes from a system that has been upgraded many times, and the original system was a version of ION Enterprise prior to 5.0. In old versions of ION Enterprise, the logical file name of ION_Network was PegasysNOM_Data and PegasysNOM_Log.
Open SQL Server Management Studio, right click on the ION_Network database and select 'Properties' to see what the Logical Names are for the database.
Resolution:
*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*
To correct this issue, rename the Logical Name to ION_Network_Data and ION_Network_Log:
Once this is done, re-run the PME Installer.
NOTE: In some situations the ION_Network database contains both the ION_Network_Data and the PegasysNOM_Data logical names. Please see FA280826 for information on how to remove the extra database files.