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Data Center Operation | Upgrade Process

Issue:
Process for obtaining the upgrade files and upgrading StruxureWare Data Center Operation.

Product Line:
StruxureWare Data Center Operation (DCO)

Environment:
StruxureWare Data Center Operation (all versions)

Cause:
Upgrade files for Data Center Operation are now provided through the EcoStruxure IT Help Center.

Resolution:

Creating a Help Center Account & Associating your Server (Online/Offline)
Upgrading the Data Center Operation Server
How to keep your product version up-to-date within the Help Center
 

EcoStruxure IT Help Center Account & Associating your Server

1) Log into your Data Center Operation (DCO) desktop client.

2) Navigate to the help menu and select Online Help.
NOTE: If when you navigate to this link it does not load the EcoStruxure IT Help Center site, proceed to the Offline Association section.

3) Log into your existing account or create a new account.

4) Select your profile image in the upper-right and then select My Products and your product should be displayed.
 

EcoStruxure IT Help Center - Offline Product Association (Alternative to online association listed above)

NOTE: Please attempt an association of your Product using the method listed above before performing and Offline Association.

1) Navigate to the EcoStruxure IT Help Center site at: https://help.ecostruxureit.com.

2) Log into an existing account or create a new account.

3) Select your profile icon in the upper-right and select My Products.

4) Complete any requirements to be able to associate your product:
- Email verification
- Country selection

5) Select the Associate offline product button.
NOTE: The button will only display once the requirements in step 4 are met.

6) Select Data Center Operation from the list and fill in the required information.

7) Click on Submit and the request for the association is sent to site administrators for approval.  Once approved, the product will display within your My Products list.
NOTE: If you are unable to click on the Request Offline Association button, please verify that the data within the fields is entered correctly.
 

Upgrading Data Center Operation

1) Within the DCO desktop client, navigate to the Help menu and select Online Help.  Log into your account.
NOTE: By accessing the upgrades this way, your product version will stay up-to-date.
NOTE: If the computer with the desktop client installed does not have access to the internet, you will need to manually log into https://help.ecostruxureit.com.

2) Select your profile image in the upper-right corner and select My Products.

3) Ensure that your product version is up-to-date. See Keeping your Product version up-to-date (section below) for details.

4) If an update is available for your Data Center Operation server you will need to select a link that will be displayed on the product listing saying "There's a new update for your product."
NOTE: If no product update is avaialble, no link will be shown.

5) If a contract has been entered by technical support for your product, the necessary upgrade files will be displayed.
NOTE: If no current software support contract is associated to your product by technical support, you will need to contact technical support to have it associated.

7) Download the upgrade file.

8) Verify the checksum of the file.  For instructions see knowledge base FA309128.

9) Follow the upgrade instructions listed here: https://help.ecostruxureit.com/display/UADCO8x/Getting+from+previous+versions+to+DCO+8.x 
 

Keeping your product version up-to-date in the Help Center

Online Associated Product

1) Log into the DCO Desktop Client.

2) Navigate to the Help menu and select Online Help.

3) Log into your existing account and your product version should now be updated.
NOTE: You can verify the upgrade by selecting your profile image in the upper-right 


Offline Associated Product

1) Log into the DCO Desktop Client.

2) Navigate to the Help Menu and select About.

3) Copy the first part of the installed version (X.X.X).

4) Navigate to https://help.ecostruxureit.com and log into your existing account.

5) Select your profile image in the upper-right and then select My Products.

6) Navigate to your Data Center Operation server within the list and click on the version number.

7) Enter the new version number retrieved within step 3 and click on the check to save.
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