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Why do any changes made in Management Console take a while to update in the PME Web Applications?
Issue
When changes are made in Management Console (New Devices, Device Renames, Changed Device Type, Logical Device changes, etc), a user has to wait in order to see these changes in PME Web Applications (Dashboards, Trends, Realtime Tables, AAV, Alarm Configuration and Hierarchy Manager).
Product Line
Power Monitoring Expert 7.2.x
Power Monitoring Expert 8.x
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Environment
Power Monitoring Expert Software Configuration
Cause
In a normal working PME, the following rules apply to how data is "propagated" through the system:
Resolution
*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*
For Power Monitoring Expert 8.1 and Later
For Power Monitoring Expert 8.0, 7.2.x
1. In SQL Management Studio, run the following script (this is a safe script to run):
USE [ApplicationModules]
-- This script will clear the ApplicationModules provider cache. It is
-- safe to run as often as you like!
DELETE FROM [ApplicationModules].DataStore.TicketResultReference
DELETE FROM [ApplicationModules].DataStore.TicketResult
GO
2. Restart service "ApplicationHost CoreServices"
When changes are made in Management Console (New Devices, Device Renames, Changed Device Type, Logical Device changes, etc), a user has to wait in order to see these changes in PME Web Applications (Dashboards, Trends, Realtime Tables, AAV, Alarm Configuration and Hierarchy Manager).
Product Line
Power Monitoring Expert 7.2.x
Power Monitoring Expert 8.x
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Environment
Power Monitoring Expert Software Configuration
Cause
In a normal working PME, the following rules apply to how data is "propagated" through the system:
- Any change in Management Console (Device changes OR new Custom Measurement detection) will be applied to AppMods every 5 minutes (or when the AppMods services are restarted)
- Any UI application that shows a list of Sources/Measurements (not counting Reporter) will cache their the list results for 15 minutes.
- This implies a worst-case delay of 20 minutes (15+5) before you see your changes in PME.
- The steps below will instantly have AppMods updated and all application cache values purged.
Resolution
*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*
For Power Monitoring Expert 8.1 and Later
These 2 steps will ensure that you can immediately see all of your changes in PME Web Applications (does not apply to Reporter):
1. Restart service "ApplicationModules CoreServicesHost"
2. Wait 10 seconds, then refresh the PME Web application in the browser that you want updated.
For Power Monitoring Expert 8.0, 7.2.x
1. In SQL Management Studio, run the following script (this is a safe script to run):
USE [ApplicationModules]
-- This script will clear the ApplicationModules provider cache. It is
-- safe to run as often as you like!
DELETE FROM [ApplicationModules].DataStore.TicketResultReference
DELETE FROM [ApplicationModules].DataStore.TicketResult
GO
2. Restart service "ApplicationHost CoreServices"
3. Wait 10 seconds, then refresh the PME Web application in the browser that you want updated.
Released for:Schneider Electric United Arab Emirates
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