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슈나이더 일렉트릭 코리아 웹사이트에 방문해 주셔서 감사합니다.

슈나이더 일렉트릭 코리아 웹사이트 방문자 분들 모두 환영합니다.
FAQ 검색
Power Monitoring Expert 7.2.x - Upgrade to Power Monitoring Expert 8.x - Failed on Step: Checking Space
Issue
When trying to upgrade Power Monitoring Expert 7.2.x to Power Monitoring Expert 8.x, the process fails on step: Checking Space.
The following error appears in the Diagnostic Log:

System.ArgumentException: Illegal characters in path.
at System.IO.Path.CheckInvalidPathChars(String path, Boolean checkAdditional)
at System.IO.Path.NormalizePath(String path, Boolean fullCheck, Int32 maxPathLength, Boolean expandShortPaths)
at System.IO.Path.GetFullPathInternal(String path)
at System.IO.FileInfo.Init(String fileName, Boolean checkHost)
at System.IO.FileInfo..ctor(String fileName)
at Installer.InstallTools.ConfigureSQL.GetDBFilePhysicalPath(String dbName)
at Installer.InstallRequests.CheckDiskSpaceGenericRequest.DoJob()

executeQuery(SELECT filename FROM sysdatabases WHERE name = 'ION_Data', master) Failed on exception:
\nSystem.InvalidCastException: Unable to cast object of type 'System.DBNull' to type 'System.String'.
at Installer.InstallTools.ConfigureSQL.ExecuteScalar(SqlCommand command, String dbName)

Product Line
Power Monitoring Expert 7.2.x
Power Monitoring Expert 8.x

Environment
Power Monitoring Expert upgrade

Cause
The SQL user/credentials selected during the installer needs to have sysadmin level user privileges. Additionally, the SQL Server services need to be running under the "Local System" account.

Resolution
To modify the user privileges of a specific SQL user:
1. Login to SQL Management Studio with a sysadmin level SQL user.
2. In the Object Explorer, navigate to Security>Logins. Double-click on the desired user selected during the PME install to open the Login Properties window.
3. Select Server Roles, and check sysadmin. Click OK to complete.

To Modify the SQL Server services log on user:
1. Open up the Windows Services.
2. Right click on the SQL Server service and select Properties
3. In the Properties window, select Log On tab, check Log on as Local System account. Click OK.
4. Perform the same for the SQL agent service.
5. Restart both the SQL and SQL Agent services.
6. Re-run the upgrade.

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