How to recover an 'ION' Windows service that is stuck in a starting or stopped state?
Issue
When an attempt is made to stop or start a Window service, it may get stuck in a stopping or starting state, or it may prompt with Error 1053: The service did not respond to the start or control request in a timely fashion.
Product Line
ION Enterprise 6.0
Power Monitoring Expert 7.x
Power Monitoring Expert 8.x
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024
Environment
Services
Cause
When troubleshooting ION Enterprise or Power Monitoring Expert it may be necessary to force stop or start a service when it is stuck in a state of "Starting" or "Stopping".
Resolution
Warning: This article contains information about modifying Windows services. Improper changes to critical Windows services can lead to system instability or crashes. These steps should only be performed by an administrator of the server.
1. In Services, right-click on the service that is stuck and select Properties
2. Note the Service name
3. Open Command Prompt with right-click > Run as Administrator
4. Run the following command, replacing <service name> with the name of the service that is stuck
taskkill /F /FI "SERVICES eq <service name>"
5. If it is successful you should receive the following message:
SUCCESS: The process with PID XXXX has been terminated.
Note:
- If the command returns "access denied", ensure that Command Prompt was opened with Run as Administrator. If doing this prompts for credentials, contact your system administrator for assistance troubleshooting and/or performing these steps
- If the command still returns "access denied", there may be a dependent service that needs to be stopped. Right-click on the service > Properties > Dependencies to view its dependent services
- If the command is unsuccessful at resolving a Windows service stuck in the "Starting" state, right-click on the service > Properties and check the following:
- On the Recovery tab, check to see if it's set to automatically restart. Try setting each failure response to "Take No Action"
- On the General tab, try setting the Service status to Manual or Disabled
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