Power Monitoring Expert Diagnostics Viewer displays "Could not load file or assembly 'ADODB, Version=7.0.3300.0"
Issue
When attempting to open the Diagnostic Viewer, the following message is displayed "could not load file or assembly 'ADODB, Version=7.0.3300.0, Culture=neutral, PublicKeyToken=b0315f7f11d50a3a' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference HRESULT: 0x80131040". The error in Diagnostic Viewer looks like image shown below:
Product Line
Power Monitoring Expert 7.2
Power Monitoring Expert 8.x
Power Monitoring Expert 9.x
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024
Environment
Diagnostic Viewer
Cause
Occurs in a distributed system when the wrong version of adodb.dll is placed in the Power Monitoring Expert/system/bin directory.
Resolution
*Warning: Take backups of any files prior to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).*
1. On the database server, navigate to the C:\Program Files (x86)\Microsoft .NET\Primary Interop Assemblies\ folder
2. Copy the adodb.dll file
3. On the Database server, navigate to the Power Monitoring Expert\system\bin folder and back up the existing adodb.dll file already present. Then, place the adodb.dll file from step 1 into this folder.
4. Next, navigate to Power Monitoring Expert\system\bin folder on the Application Server and back up the existing adodb.dll file already present. Then, place the adodb.dll file from step 1 into this folder.
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