PME 8.1: Dials in Web Applications are showing incorrect scaling
Issue
In PME 8.1 web applications, the dials shown within the diagrams are maxed out or incorrectly scaled when compared to the same dials viewed in Vista.
Example: Dials displayed in Web Applications

Example: Dials displayed in Vista

Product Line
Power Monitoring Expert 8.1
Environment
Power Monitoring Expert
Web Applications, Vista
Cause
The scaling in gauges in Diagrams will not work if a lower case 'k' or 'g' or 'm' is used in the units field.
Resolution
*Warning: Take backups of any files pirot to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).
The issue has been addressed by a hotfix, attached below, for PME 8.1 released in August 2016.
To deploy:
1. Navigate to the following default directory on the PME server: C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\system\WebReach
2. Backup the existing versions of the following files to a safe location:
4. Restart the ApplicationModules CoreSeviceshot service and its dependent services.
5. Clear browser caches and reset IIS after copying in the updated files.
In PME 8.1 web applications, the dials shown within the diagrams are maxed out or incorrectly scaled when compared to the same dials viewed in Vista.
Example: Dials displayed in Web Applications
Example: Dials displayed in Vista
Product Line
Power Monitoring Expert 8.1
Environment
Power Monitoring Expert
Web Applications, Vista
Cause
The scaling in gauges in Diagrams will not work if a lower case 'k' or 'g' or 'm' is used in the units field.
Resolution
*Warning: Take backups of any files pirot to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).
The issue has been addressed by a hotfix, attached below, for PME 8.1 released in August 2016.
To deploy:
1. Navigate to the following default directory on the PME server: C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\system\WebReach
2. Backup the existing versions of the following files to a safe location:
- historical\displaylogs.aspx
- scripts\realtime.js
- default.aspx
4. Restart the ApplicationModules CoreSeviceshot service and its dependent services.
5. Clear browser caches and reset IIS after copying in the updated files.
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