브랜드

Impact-Company-Logo-English Black-01-177x54

슈나이더 일렉트릭 코리아 웹사이트에 방문해 주셔서 감사합니다.

슈나이더 일렉트릭 코리아 웹사이트 방문자 분들 모두 환영합니다.
		
오늘 무엇을 도와드릴까요?
Power Monitoring Expert - When I upgrade to a newer version of PME, why do I get a pop up dialog asking me to insert the 'RegBrick_x86.msi' disk?

Issue

Power Monitoring Expert - When I upgrade to a newer version of PME, why do I get a pop up dialog asking me to insert the 'RegBrick_x86.msi' disk?

Product Line

Struxureware Power Monitoring 7.0(SPM)

Power Monitoring Expert 7.2.x

Power Monitoring Expert 8.x

Power Monitoring Expert 9.0

Cause

RegBrick_x86.msi is a third party component that is used by PME. It is sometimes flagged by anti-virus software (McAfee for sure and possibly other anti-virus programs) as a Trojan and so it gets moved by the anti-virus software to a quarantine folder.
Part of the PME upgrade process is to uninstall the old msi packages prior to installing the newer versions. Because the RegBrick_x86 information has been removed from its expected location, the PME installer is unable to proceed and pops up a dialog (see attached screen cap)


Resolution
Recommended workaround
Browse to the Microsoft link below:

https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed

Download the 'Program Install and Uninstall Troubleshooter' tool and save it locally.
Run the tool and choose 'RegBrick_x86' from the list of programs that will be presented (see attached screen cap)
Then click on 'Yes, try uninstall' (see attached screen cap)
Once this has been done, the PME upgrade will proceed without this problem.

Another Workaround
You will need the iso from the version of PME that you are upgrading from. If you have that, when the popup dialog appears, browse the iso to RegBrick_x86.msi. It can be found in the \setup\installers folder on the iso. Note that you need the exact version of RegBrick_x86.msi that corresponds to the version you are upgrading from.

Additional Information
The Registration Brick component is being removed for Power Monitoring Expert 9.0. If older PME systems are upgraded to PME 9.0, the Registration Brick component does not get uninstalled, but this will not cause any problems. If desired, it is possible to remove this orphaned component by following the steps above.


슈나이더 일렉트릭 Korea

첨부 파일
RegBrick_Tool_Program_list.png [16.28 KB]
RegBrick_popup.png [8.36 KB]
RegBrick_tool_uninstall.png [11.84 KB]
자세히 알아보기
제품군
자세히 알아보기
제품군
  • 제품 문서
  • 소프트웨어 다운로드
  • 제품 선택기
  • 제품 대체 및 교체
  • 지원 및 연락처 센터
  • 영업소 검색
  • 견적 받기
  • 슈나이더 일렉트릭 커뮤니티
  • 채용
  • 회사 소개
  • 부정 행위 보고
  • 접근성
  • 뉴스룸
  • 투자자
  • Ecostruxure
  • 작업 검색
  • 블로그
  • 개인정보 취급방침
  • 쿠키 공지
  • 사용 약관
  • Change your cookie settings