Power Monitoring Expert - When I upgrade to a newer version of PME, why do I get a pop up dialog asking me to insert the 'RegBrick_x86.msi' disk?
Issue
Power Monitoring Expert - When I upgrade to a newer version of PME, why do I get a pop up dialog asking me to insert the 'RegBrick_x86.msi' disk?
Product Line
Struxureware Power Monitoring 7.0(SPM)
Power Monitoring Expert 7.2.x
Power Monitoring Expert 8.x
Power Monitoring Expert 9.0
Cause
RegBrick_x86.msi is a third party component that is used by PME. It is sometimes flagged by anti-virus software (McAfee for sure and possibly other anti-virus programs) as a Trojan and so it gets moved by the anti-virus software to a quarantine folder.
Part of the PME upgrade process is to uninstall the old msi packages prior to installing the newer versions. Because the RegBrick_x86 information has been removed from its expected location, the PME installer is unable to proceed and pops up a dialog (see attached screen cap)
Resolution
Recommended workaround
Browse to the Microsoft link below:
https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed
Download the 'Program Install and Uninstall Troubleshooter' tool and save it locally.
Run the tool and choose 'RegBrick_x86' from the list of programs that will be presented (see attached screen cap)
Then click on 'Yes, try uninstall' (see attached screen cap)
Once this has been done, the PME upgrade will proceed without this problem.
Another Workaround
You will need the iso from the version of PME that you are upgrading from. If you have that, when the popup dialog appears, browse the iso to RegBrick_x86.msi. It can be found in the \setup\installers folder on the iso. Note that you need the exact version of RegBrick_x86.msi that corresponds to the version you are upgrading from.
Additional Information
The Registration Brick component is being removed for Power Monitoring Expert 9.0. If older PME systems are upgraded to PME 9.0, the Registration Brick component does not get uninstalled, but this will not cause any problems. If desired, it is possible to remove this orphaned component by following the steps above.
게시 대상: 슈나이더 일렉트릭 Korea


도움이 필요하신가요?
제품 선택기
애플리케이션에 적합한 제품과 액세서리를 빠르고 쉽게 찾을 수 있습니다.
견적 받기
영업 관련하여 온라인으로 문의하시면 전문가가 연락드립니다.
구매처
해당 지역의 가장 가까운 슈나이더 일렉트릭 대리점을 쉽게 찾을 수 있습니다.
지원 센터
한 곳에서 모든 요구 사항에 대한 지원 리소스를 찾아보십시오.