ENM 8.3 does not load tags from Power Monitoring Expert, 'Utility.UpdateEfSourcesException' in the diagnostic page
Issue
After configuring ENM to connect to Power Monitoring Expert (PME), ENM is able to observe events coming from PME however no tags are loaded. Diagnostic log contains the following error:
"An exception of type 'Utility.UpdateEfSourcesException' occurred and was caught."
Product
ENM 8.3 with PME 8.X
Environment
Internet Explorer
Cause
A SQL stored procedure has a variable defined as text rather than nvarchar
Resolution
*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*
1) Open SQL Server Management Studio (SSMS) and connect to the instance where the ENM databases are located
2) In the object explorer, expand the databases-> PLES_APM -> Programmability -> Stored Procedures
3) Locate [PLES_APM].[dbo].[usp_MM_xml_UpdateNodeSet] and right click on the procedure -> Tasks -> ALTER to -> New Query Editor Window
4) Search for "@Data text" (without quotes) and replace with "@Data nvarchar(max)" (without quotes)
5) Execute the statement
6) Repeat steps 3 through 5 for the stored procedure [PLES_APM].[dbo].[usp_xml_UpdateNodeSet]
게시 대상: 슈나이더 일렉트릭 Korea








도움이 필요하신가요?
제품 선택기
애플리케이션에 적합한 제품과 액세서리를 빠르고 쉽게 찾을 수 있습니다.
견적 받기
영업 관련하여 온라인으로 문의하시면 전문가가 연락드립니다.
구매처
해당 지역의 가장 가까운 슈나이더 일렉트릭 대리점을 쉽게 찾을 수 있습니다.
지원 센터
한 곳에서 모든 요구 사항에 대한 지원 리소스를 찾아보십시오.