Power Monitoring Expert - Insufficient SQL Server Role to open Database Manager
Issue:
The following error is displayed when trying to open the Database Manager: cannot open the Database Manager. To open the Database Manager a user must be a member of the SQL sysadmin server role.
Product Line:
Power Monitoring Expert 7.2.2
Power Monitoring Expert 8.2
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024
Environment:
Database Manager
SQL Server Management Studio (SSMS)
Cause:
The 'sysadmin' role is not applied to the user account in SQL.
Resolution:
In order to use the Database Manager in Power Monitoring Expert 8.1 and newer, the user must log into Windows using an account that has been granted 'sysadmin' role in SQL Server Management Studio.
*Warning: Irreparable Database Damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*
Note: In some cases, a domain account may appear to have the 'sysadmin' role checked in SQL but are still unable to log in due to domain policy restrictions. To check and see if the user account does indeed have 'sysadmin' rights, the following query can be run in SQL Server Management Studio.
SELECT name, type_desc, is_disabled
FROM master.sys.server_principals
WHERE IS_SRVROLEMEMBER ('sysadmin',name)=1
ORDER BY name
If the user that you are logged into SSMS with is not returned, the user does not have sysadmin rights.
Note: More information on how to determine if a SQL Server login is a member of a specified server role can be found in FA346467 .
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