PME 9.0 - LogSubSystem services won't start
Issue
After upgrading/migrating the system or a fresh installation the installer will fail at "Start Services" and "Verify Registered Service" at the final stage. It will state that the PMLOGROUTER exceeded the timeout of 300 seconds.
PMLOGROUTER refers to LogSubSystem service.
Product Line
Power Monitoring Expert 9.0 (including with the CU1 applied)
Environment
Upgrade - Migration - New Installation for PME 9.0
Cause
The LogSubSystem service will fail to create the Message Queues under Computer Management > Services and Application > Message Queuing > Private Queues due to the server name being longer than 15 characters - therefore the service will not start and no data will be logged into the database.
When trying to unregister this service and register it back again through the command prompt, it will give the following error message:
Could not create primary data router message queues: Could not initialize standard queues for Queue: LogSubsystemPrimaryRouter@STANDALONE-TEST-PME: Could not create queue: ("STANDALONE-TEST-PME\private$\LogSubsystemPrimaryRouter_Data", "") at step check exists: Invalid queue path name.; ErrorCode: [IllegalQueuePathName]. The router will attempt to create the queues each time it starts.
PME has always worked as expected in the previous version because it uses the NetBIOS name of the computer, which is limited to 15 bytes, however, this service has been introduced in PME 9.0 and it will use the full name as it uses Microsoft Message Queueing.
Resolution
The PME 9.0 - System Guide is very specific regarding the PME Serve Name Limitations (page 51 - Other IT Considerations), where it states that the computer name for the PME server MUST have 15 characters or less, and use only letters, numbers, or the "_" character.
Please follow the steps:
Applying the CU1 will NOT fix the issue.
Although this specific server will fail to start, PME database will use the NetBios shortened to 15 bytes - so the system will work normally if the server name matches the one found in the databases.
After upgrading/migrating the system or a fresh installation the installer will fail at "Start Services" and "Verify Registered Service" at the final stage. It will state that the PMLOGROUTER exceeded the timeout of 300 seconds.
PMLOGROUTER refers to LogSubSystem service.
Product Line
Power Monitoring Expert 9.0 (including with the CU1 applied)
Environment
Upgrade - Migration - New Installation for PME 9.0
Cause
The LogSubSystem service will fail to create the Message Queues under Computer Management > Services and Application > Message Queuing > Private Queues due to the server name being longer than 15 characters - therefore the service will not start and no data will be logged into the database.
When trying to unregister this service and register it back again through the command prompt, it will give the following error message:
Could not create primary data router message queues: Could not initialize standard queues for Queue: LogSubsystemPrimaryRouter@STANDALONE-TEST-PME: Could not create queue: ("STANDALONE-TEST-PME\private$\LogSubsystemPrimaryRouter_Data", "") at step check exists: Invalid queue path name.; ErrorCode: [IllegalQueuePathName]. The router will attempt to create the queues each time it starts.
PME has always worked as expected in the previous version because it uses the NetBIOS name of the computer, which is limited to 15 bytes, however, this service has been introduced in PME 9.0 and it will use the full name as it uses Microsoft Message Queueing.
Resolution
The PME 9.0 - System Guide is very specific regarding the PME Serve Name Limitations (page 51 - Other IT Considerations), where it states that the computer name for the PME server MUST have 15 characters or less, and use only letters, numbers, or the "_" character.
Please follow the steps:
1- Check the server name: Open SSMS > ION_Network > dbo.Machine
2- Rename the server (in System Properties > Computer Name/Domain Changes > Computer Name) to MATCH the name found in the database - THIS IS VERY IMPORTANT - It has to be the same otherwise the system won't work.
3- Reboot the server
4- Logged as administrator, open the command prompt
2- Rename the server (in System Properties > Computer Name/Domain Changes > Computer Name) to MATCH the name found in the database - THIS IS VERY IMPORTANT - It has to be the same otherwise the system won't work.
3- Reboot the server
4- Logged as administrator, open the command prompt
Run the command to remove the service:
LogSubsystem.Service.exe -UnregServer
LogSubsystem.Service.exe -UnregServer
Run the command to add the service back:
LogSubsystem.Service.exe -Service
LogSubsystem.Service.exe -Service
5 - Go to Computer Management > Services and Application > Message Queuing > Private Queues and check if the queues referring to this service were created
6 - Start the LogSubSystem service under Windows Service
6 - Start the LogSubSystem service under Windows Service
Applying the CU1 will NOT fix the issue.
Although this specific server will fail to start, PME database will use the NetBios shortened to 15 bytes - so the system will work normally if the server name matches the one found in the databases.
게시 대상: 슈나이더 일렉트릭 Korea
도움이 필요하신가요?
제품 선택기
애플리케이션에 적합한 제품과 액세서리를 빠르고 쉽게 찾을 수 있습니다.
견적 받기
영업 관련하여 온라인으로 문의하시면 전문가가 연락드립니다.
구매처
해당 지역의 가장 가까운 슈나이더 일렉트릭 대리점을 쉽게 찾을 수 있습니다.
지원 센터
한 곳에서 모든 요구 사항에 대한 지원 리소스를 찾아보십시오.