Power Monitoring Expert (PME) Web Apps Software Alarms won't trigger
Issue
Software alarms created in PME web apps aren't triggering even when the criteria of the alarm is forced to be met.
Product Line
Power Monitoring Expert 9.0, Power Monitoring Expert 2020
Enviroment
PME Web Applications
PME Alarms
Windows Message Queue
Cause
The alarms aren not being activated due to lack of permission in the Message Queue.
Resolution
- Login as administrator of the server.
- Click the windows button in the bottom left of the desktop and search for "Computer Management"
- Open Computer management and Expand "Services and Applications" -> Message Queues
- You might as well check permissions for all of the private queues by right clicking on each of them and checking Properties -> SecurityList of private queues to check: cloudagent_control, cloudagent_data, logsubsystemprimaryrouter_control, logsubsystemprimaryrouter_data, logsubsystemsecondaryrouter_control, logsubsystemsecondaryrouter_data.
Make sure each of these queues has the following permissions
"Everyone" group has access to allow:
- Get Properties
- Get Permissions
- Send Message
"Administrators" group should have full access to the queue.
"ANONYMOUS LOGON" Group should only have access to:
- Send Message
If this is already setup this way and the problem remains, add domain group to the security tab and allow permissions to:
- Get Properties
- Get Permissions
- Send Message
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