How to setup Debug Diagnostic to get dump files for PSO troubleshooting
Issue
How to extract dump files from PSO processes. This is useful when an exception has occurred.
Product Line
Debug Diagnostic
Environment
PowerSCADA Operation (PSO)
Cause
The Debug Diagnostic Tool (DebugDiag) is designed to assist in troubleshooting issues such as hangs, slow performance, memory leaks or memory fragmentation, and crashes in any user-mode process.
Resolution
While the attached document outlines the procedure with screenshots, below are the steps:
How to extract dump files from PSO processes. This is useful when an exception has occurred.
Product Line
Debug Diagnostic
Environment
PowerSCADA Operation (PSO)
Cause
The Debug Diagnostic Tool (DebugDiag) is designed to assist in troubleshooting issues such as hangs, slow performance, memory leaks or memory fragmentation, and crashes in any user-mode process.
Resolution
While the attached document outlines the procedure with screenshots, below are the steps:
- Download debug diagnostics from: https://www.microsoft.com/en-us/download/details.aspx?id=58210
- Start up the “DebugDiag 2 Collection” application and press “Cancel” on the “Select Rule Type” popup.
- Switch to the “Processes” tab
- Select the “CitectIDE.exe” process, right click and select “Create Full Userdump”
- Select the “CtDraw32.exe” process, right click and select “Create Full Userdump”
- Collect the two dumps from the specified location and send them to support!
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