Power Monitoring Expert - Software Alarms not showing up in Alarm Viewer
Issue
Alarms are not coming up in the Alarm Viewer for devices.
Product Line
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Environment
Alarm Viewer - Web Application
Cause
PME has insufficient permission to send messages to the queues.
Error message in SystemLog:
Resolution
1) Login as an administrator of the server.
2) Click the Windows button in the bottom left of the desktop and search for "Computer Management"
3) Open Computer Management and Expand "Services and Applications" -> Message Queues
4) You might as well check permissions for all of the private queues by right-clicking on each of them and checking Properties -> Security
List of private queues to check:
Make sure each of these queues has the following permissions
"Everyone" group has access to allow:
"Administrators" group should have full access to the queue.
"ANONYMOUS LOGON" Group should only have access to:
5) Restart the Log Subsystem Router Service
Note:
Alarms are not coming up in the Alarm Viewer for devices.
Product Line
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Environment
Alarm Viewer - Web Application
Cause
PME has insufficient permission to send messages to the queues.
Error message in SystemLog:
| Service | LogAcquisitionMessenger | Computer General | SERVER | Message Write Failure: Error sending message on queue '.\private$\LogSubsystemPrimaryRouter_Data'.; ErrorCode: [AccessDenied]; Body: DataMessage: Operation [Insert]; Filtered [False] Retry [0] (This message has been repeated 0 times.) |
Resolution
1) Login as an administrator of the server.
2) Click the Windows button in the bottom left of the desktop and search for "Computer Management"
3) Open Computer Management and Expand "Services and Applications" -> Message Queues
4) You might as well check permissions for all of the private queues by right-clicking on each of them and checking Properties -> Security
List of private queues to check:
- cloudagent_control, cloudagent_data, cloudagent_retry
- logsubsystemprimaryrouter_control
- logsubsystemprimaryrouter_data
- logsubsystemprimaryrouter_retry
- logsubsystemsecondaryrouter_control
- logsubsystemsecondaryrouter_data
- logsubsystemsecondaryrouter_retry
Make sure each of these queues has the following permissions
"Everyone" group has access to allow:
- Get Properties
- Get Permissions
- Send Message
"Administrators" group should have full access to the queue.
"ANONYMOUS LOGON" Group should only have access to:
- Send Message
5) Restart the Log Subsystem Router Service
Note:
If this is already setup this way and the problem remains, add domain group to the security tab and allow permissions to:
- Get Properties
- Get Permissions
- Send Message
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