Issues updating NMC firmware via the Secure Network System Tool, when Multi-factor Authentication is enabled
Issue:
Firmware updates via the Secure NMC System Tool, EcoStruxure IT Expert, and Data Center Expert are unsuccessful if multi-factor authentication (MFA) is enabled and there is no local user account on the NMC without an email address
Cause:
NMC3 AOS firmware v3.4 has added support for multi-factor authentication (MFA) via a one-time password. If MFA is enabled on NMC3 devices and there is no local user account configured without an email address, firmware updates will be unsuccessful in the Secure NMC System Tool, EcoStruxure IT Expert, and Data Center Expert.
Product Line:
Network Management Card 3 (NMC3) - AP9640, AP9641, AP9643, and devices with an embedded NMC3
Network Management Card 3 (NMC3) - AP9640, AP9641, AP9643, and devices with an embedded NMC3
Solution:
For NMC3 devices with multi-factor authentication (MFA) enabled, ensure there is at least one local user that does not have an email address (and therefore MFA does not apply) for use with the Secure NMC System Tool, EcoStruxure IT Expert, and Data Center Expert.
In the NMC3 Web UI, local user configuration and email address can be verified by:
1. Navigate to Configuration > Security > Local Users > Management.
2. In the user list, verify that the E-mail Address value is blank for the local user that will be used for the Secure NMC System Tool.
3. If it is not blank, click on the user to modify the settings and remove the E-mail Address.
1. Navigate to Configuration > Security > Local Users > Management.
2. In the user list, verify that the E-mail Address value is blank for the local user that will be used for the Secure NMC System Tool.
3. If it is not blank, click on the user to modify the settings and remove the E-mail Address.
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