SoMove Launch Issue: "SoMove.Launcher" encountered an unexpected problem.
Issue:
SoMove v2.10 or v2.11 will not launch after installation.
The error seen is:
Unhandled exception detected.
"SoMove.Launcher" encountered an unexpected problem.
ExceptionReport
Exception dialog created at: 10/29/2025 11:50.36AM
System.lO.FileNotFoundException: Could not bad file or assembly 'System.ServiceModel, Version=3.0.0.0, Culture=neutral,
PublicKeyToken=b77aScS61934e089' or one of its dependencies. The system cannot find the file specified.
File name: 'System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77aScS61934e08Y
at PowerSuite.Launcher.ShelLauncher.Main(String[] args)
Product Lines:
Altivar Drives
Lexium Servo
TeSys T Motor Starters
Environment:
Windows 11
Cause:
.NET Framework 3.5 is not installed on Windows 11
Resolution:
Enable .NET Framework 3.5 on Windows
1) Press the Start button on the taskbar.
2) Search for Windows Features and open it. The Turn Windows features on or off dialog box appears.
3) Select the .NET Framework 3.5 (includes .NET 2.0 and 3.0) check box, select OK, and reboot your computer if prompted.
4) Select the child items for Windows Communication Foundation (WCF) HTTP Activation and Windows Communication Foundation (WCF) Non-HTTP Activation.
5) Restart the PC and Launch Somove.
If this FAQ did not solve your issue, you can chat with us at chat with us or e-mail us at customer.services@se.com to create a case with our Technical Support Team.
If you are not located in North America, please contact your local Customer Care Center for assistance:
Support | Schneider Electric Global (se.com)
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