Alarms Stuck Processing Post Upgrade
Issue:
Commonly, after an upgrade, when the Alarms tab in Web Applications is opened there will be a message saying "Alarms is processing existing records for first time use. The Alarms application will be ready for use once the historical processing is complete."
Product Line:
Power Monitoring Expert (PME) 2021
Power Monitoring Expert (PME) 2022
Power Monitoring Expert (PME) 2023
Power Monitoring Expert (PME) 2024
Cause:
After an upgrade, the events in the database are processed. If there are a large number of events that are saved in the database, it will take time for the events to be processed. The script below in the resolution will clear the flag for the processing alarms and allow you to view the alarms while they continue to process in the background.
Resolution:
The script below will remove the above Note and corresponding box to allow you to look at the Alarms page. Before running this script, please go into the Services application on Windows and stop the ION Log Subsystem Router Service and verify that the ION Application Modules Alarm Service Host are stopped.
UPDATE ApplicationModules.Configuration.ConfigurationSettings
SET [Value] = 'True'
WHERE item = 'Alarm Service Processing' and [Key] = 'AlarmProcessorHasCompletedFullBackfill'
Restart the ION Log Subsystem Router Service after executing the script to continue the processing of alarms in the background.
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