Video: How can I download Event, Data, Configuration, and Debug files from my Network Management Card?
Published date:
Issue
Environment
Cause
You can download Event and Data logs from a Network Management Card (NMC) as well as any configuration files directly from the Network Management Card. This is helpful in situations that require backup of data and/or settings or when troubleshooting. In certain situations, additional debug files may be requested. This is typically done using the FTP protocol but other options exist depending on your device type and current configuration.
Resolution
Refer to the instructions below which cover FTP or SCP, download via Web UI (if available), and via the Command Line Interface (CLI) (if available).
To begin, here is a list of what files are available from each card:
File Transfer Protocol - All Network Management Cards or Web/SNMP Card
Please follow the procedure below for FTP instructions on v3.X.X, v5.X.X, and v6.X.X firmware versions. These same steps could also be used for SCP in some form.
Network Management Card 2 (AP9630/31/35) v6.0.6 and higher, Network Management Card 3 (AP9640/41) - How to Export Logs (data.txt, event.txt, or config.ini only) via the Web UI
Alternatively, if files are requested by technical support, a single debug file download, including event.txt and data.txt with many other files can be obtained via the web interface under About > Support > Generate Logs and subsequently Download logs. This same generation/download can be completed via the logzip CLI command and then FTP/SCP to download the single file from the /dbg directory.
https://www.youtube.com/watch?v=guo8BXKVFms
Proceed below if only event.txt, data.txt, and config.ini are required.
1.) Log into the Network Management Card via a supported web browser.
2.) Navigate to the Logs menu and choose either Data > Log or Event >Log.
3.) Select the floppy disk icon, as shown below and you can export either data.txt or event.txt directly from the Web UI to your local computer from the disk icon in their respective menus.
4.) Choose a location on your local computer to save the file with the dialog box that pops up.
5.) For the config.ini file, navigate to Configuration > General > User Config File and click the Download button, shown below.
After selecting Download, a dialog box should appear for you to save your file to your local computer.
Network Management Card 2 (AP9630/31/35) v6.0.6 and higher, Network Management Card (AP9640/41) - How to Export "Debug File Download" via Command Line Interface
These steps are helpful if web access is unavailable or not allowed.
1.) Connect to the Network Management Card 2/3 via the CLI (Telnet, SSH, or local console).
2.) Issue the logzip command. During this process, the Network Management Card will generate a file called debug_<serial number of card>.tar. NOTE:For NMC3: The dbg directory is not included in the Smart-UPS (su) firmware and needs to be manually downloaded. Follow the steps outlined in Knowledge Base article FA386512 to download the dbg directory contents.
Example:
apc>logzip
Generating files
Compressing files into /dbg/debug_ZA123456789.tar
E000: Success
3.) Now the .tar file needs to be retrieved. Connect to the card via FTP or Secure CoPy. Log in via your preferred method and verify the file is present in the /dbg directory.
Example (via FTP):
220 AP8841 Network Management Card AOS v6.1.3 FTP server ready.
User (10.10.10.96:(none)): apc
331 User name okay, need password.
Password: <hidden>
230 User logged in, proceed.
ftp> bin
200 TYPE Command okay.
ftp> hash
Hash mark printing On ftp: (2048 bytes/hash mark) .
ftp> cd /dbg
250 CWD requested file action okay, completed.
ftp> ls
200 PORT Command okay.
150 File status okay; about to open data connection.
./
../
debug_ZA123456789.tar
226 Closing data connection.
ftp: 33 bytes received in 0.00Seconds 16.50Kbytes/sec.
After verifying the file is present, download it. Change your local directory prior, if necessary. (This can be done by using the LCD ftp command.)
ftp>get <space>debug_ZA123456789.tar
150 File status okay; about to open data connection.
226 Closing data connection.
ftp: 2048 bytes received in 2.31 Seconds 16.50Kbytes/sec.
4.) Locate the file for storage or to provide to technical support.
Published date:
Issue
- Technical Support has requested log files for review
- The user wishes to view available log files
- The user would like to back up one or more files.
- Web/SNMP Card - AP9606
- Network Management Card 1 (NMC1) - AP9617, AP9618, AP9619
- Network Management Card 2 (NMC2) - AP9630/AP9630CH, AP9631/AP9631CH, AP9635/AP9635CH
- Network Management Card 3 (NMC3) – AP9640, AP9641
Environment
- All serial numbers
- All firmware versions (unless otherwise noted)
Cause
You can download Event and Data logs from a Network Management Card (NMC) as well as any configuration files directly from the Network Management Card. This is helpful in situations that require backup of data and/or settings or when troubleshooting. In certain situations, additional debug files may be requested. This is typically done using the FTP protocol but other options exist depending on your device type and current configuration.
Resolution
Refer to the instructions below which cover FTP or SCP, download via Web UI (if available), and via the Command Line Interface (CLI) (if available).
To begin, here is a list of what files are available from each card:
- Web/SNMP Card (AP9606)
- Available file includes: event.txt
- Network Management Card 1 (AP9617, AP9618, AP9619)
- Available files include: event.txt, data.txt, and config.ini
- Network Management Card 2 (AP9630, AP9631, AP9635)
- Available files include: event.txt, data.txt, config.ini, debug.txt, dump.txt, select UPS debug files (v6.0.6 and higher only)
- Network Management Card 3 (AP9640, AP9641)
- Available files include: event.txt, data.txt, config.ini, debug.txt, dump.txt, select UPS debug files
File Transfer Protocol - All Network Management Cards or Web/SNMP Card
Please follow the procedure below for FTP instructions on v3.X.X, v5.X.X, and v6.X.X firmware versions. These same steps could also be used for SCP in some form.
-
- Open a command prompt (In a Windows environment: Start > run > "cmd") or other client that supports the FTP protocol.
2.) Change directories to the directory that you want the files stored in. Generally, you'd use the cd command in most command line tools. If using a GUI FTP client, this may not be necessary.
3.) Type ftp<space><IP address of Network Management Card>. Press enter.
4.) Log into the Network Management Card with an Administrator login.
5.) Type bin. Press enter. (This will change into binary transfer mode, as opposed to ASCII.)
6.) Type hash. Press enter. (This will display hash marks - # - on the screen to indicate data transfer).
7.) At your command prompt, type get config.ini. Press enter.
8.) NOTE:*If using Network Management Card 2 only, files are now stored in the /logs directory on the card. Even so, backwards compatibility is built in so that these files can be retrieved from the root directory. Alternatively, you can also change to the logs directory to get the files. To do so, type cd logs.
9.) Type get<space>data.txt. Press enter.
10.) Type get<space>event.txt. Press enter.
11.) Optional: If requested to do so, change to the /dbg directory by typing cd<space>/dbg and type get<space>debug.txt and/or get<space>dump.txt. NOTE:For NMC3: The dbg directory is not included in the Smart-UPS (su) firmware and needs to be manually downloaded. Follow the steps outlined in Knowledge Base article FA386512 to download the dbg directory contents.
12.) The files have now been downloaded and are saved to the directory that was specified in step 2.
13.) Type bye and exit out of your command prompt or FTP client.
- Open a command prompt (In a Windows environment: Start > run > "cmd") or other client that supports the FTP protocol.
Network Management Card 2 (AP9630/31/35) v6.0.6 and higher, Network Management Card 3 (AP9640/41) - How to Export Logs (data.txt, event.txt, or config.ini only) via the Web UI
Alternatively, if files are requested by technical support, a single debug file download, including event.txt and data.txt with many other files can be obtained via the web interface under About > Support > Generate Logs and subsequently Download logs. This same generation/download can be completed via the logzip CLI command and then FTP/SCP to download the single file from the /dbg directory.
https://www.youtube.com/watch?v=guo8BXKVFms
Proceed below if only event.txt, data.txt, and config.ini are required.
1.) Log into the Network Management Card via a supported web browser.
2.) Navigate to the Logs menu and choose either Data > Log or Event >Log.
3.) Select the floppy disk icon, as shown below and you can export either data.txt or event.txt directly from the Web UI to your local computer from the disk icon in their respective menus.
4.) Choose a location on your local computer to save the file with the dialog box that pops up.
5.) For the config.ini file, navigate to Configuration > General > User Config File and click the Download button, shown below.
After selecting Download, a dialog box should appear for you to save your file to your local computer.
Network Management Card 2 (AP9630/31/35) v6.0.6 and higher, Network Management Card (AP9640/41) - How to Export "Debug File Download" via Command Line Interface
These steps are helpful if web access is unavailable or not allowed.
1.) Connect to the Network Management Card 2/3 via the CLI (Telnet, SSH, or local console).
2.) Issue the logzip command. During this process, the Network Management Card will generate a file called debug_<serial number of card>.tar. NOTE:For NMC3: The dbg directory is not included in the Smart-UPS (su) firmware and needs to be manually downloaded. Follow the steps outlined in Knowledge Base article FA386512 to download the dbg directory contents.
Example:
apc>logzip
Generating files
Compressing files into /dbg/debug_ZA123456789.tar
E000: Success
3.) Now the .tar file needs to be retrieved. Connect to the card via FTP or Secure CoPy. Log in via your preferred method and verify the file is present in the /dbg directory.
Example (via FTP):
220 AP8841 Network Management Card AOS v6.1.3 FTP server ready.
User (10.10.10.96:(none)): apc
331 User name okay, need password.
Password: <hidden>
230 User logged in, proceed.
ftp> bin
200 TYPE Command okay.
ftp> hash
Hash mark printing On ftp: (2048 bytes/hash mark) .
ftp> cd /dbg
250 CWD requested file action okay, completed.
ftp> ls
200 PORT Command okay.
150 File status okay; about to open data connection.
./
../
debug_ZA123456789.tar
226 Closing data connection.
ftp: 33 bytes received in 0.00Seconds 16.50Kbytes/sec.
After verifying the file is present, download it. Change your local directory prior, if necessary. (This can be done by using the LCD ftp command.)
ftp>get <space>debug_ZA123456789.tar
150 File status okay; about to open data connection.
226 Closing data connection.
ftp: 2048 bytes received in 2.31 Seconds 16.50Kbytes/sec.
4.) Locate the file for storage or to provide to technical support.