Browse FAQs

How to configure PME to work with HTTPS with SSL enabled?

Published date: 09 June 2020

Issue
Enabling SSL on the PME webpage and requiring HTTPS causes the webpage to no longer work. 

Product Line
StruxureWare Power Monitoring 7.0.x
Power Monitoring Expert 7.2.x
Power Monitoring Expert 8.x
Internet Explorer 10, 11

Environment
Power Monitoring Expert Web Applications

Cause

The PME webpage uses hard coded HTTP links in the various web.config files. When the webpage is set to require HTTPS within IIS, the website breaks due to these links. 

Resolution
The attached documents details the steps required to enable HTTPS with SSL encryption.

Was this helpful?

What can we do to improve the information ?

Can't find what you are looking for?

Reach out to our customer care team to receive information on technical support, assistance for complaints and more.