Browse FAQs

How to test if the browser supports TLS 1.2 Protocol

Published date: 30 April 2020

Issue
Does the browser supports TLS 1.2?

Product Line
Power Monitoring Expert 2020 (PME2020)

Environment
browser (Internet Explorer, Chrome, Edge)

Cause
Older versions of TLS are becoming obsolete and need to be disabled. PME2020 supports TLS 1.2 and this feature needs to be enabled. However, one needs to first test if TLS 1.2 is supported by the current browser or not. If not, the browser needs to be upgraded.

Resolution
To check if the browser can handle TLS v1.2:

- Select https://www.ssllabs.com/ssltest/viewMyClient.html link to open the SSL/TLS Capabilities of Your Browser page

NOTE: copy the link to test in different browsers

- Once the page completes the test, scroll down to the Protocol Features section

- If Yes is displayed next to TLS 1.2, your browser will continue to work


          
 

Was this helpful?

What can we do to improve the information ?

Can't find what you are looking for?

Reach out to our customer care team to receive information on technical support, assistance for complaints and more.