Power Monitoring Expert (PME) Empty Data logs in Vista but the Diagram shows data
Issue
In the Power Monitoring Expert (PME) Vista application diagrams, when a data log object is selected, a new window appears, but there is no data. This occurs across multiple diagrams and devices where data is expected. (It is assumed the data log is correctly linked. In the PME databases, SQL data is logging, and the diagrams show live data when the data log object is selected.
Product Line
Power Monitoring Expert 8.x
Power Monitoring Expert 9.x
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024
Environment
PME Vista
Windows Services
Cause
PME uses several ION services in the Windows Services. From the PME 2024 official system guide, the ION Query Service "Provides historical data retrieval from the ION_Data database for client applications (for example, Vista and Diagrams)." This service can be stalled or "hung" and requires a refresh so the PME Vista application can retrieve the data logs.
Resolution
- In the start menu, search for "Services" and open the app
- Scroll to find and select the "ION Query Service"
- Right-click and select "restart" to restart the service
- Alternatively, press the green arrow symbol in the toolbar to start
- If the service is started, the "status" column should say "Running
- To confirm the correct PME Query Server is being used, right-click on empty space in a Vista diagram and select "properties"
- In the properties window, confirm that the Query Server for your PME system is shown
Recommendation:If you are using an older version of PME, consider upgrading to the latest version for improved protocol support and security. For assistance with integration or upgrades, contact Schneider Electric Order Support at: pmo.support@se.com