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Power Monitoring Expert - Vista error "Query timeout expired"

Issue
Customer receives the following error when attempting to view a Datalog viewer in Vista: "Query timeout expired"

Product Line
ION Enterprise 5.x
ION Enterprise 6.x
Struxureware Power Monitoring 7.0.x
Power Monitoring Expert 7.2.x
Power Monitoring Expert 8.x
Power Monitoring Expert 9.x

Environment
Vista

Cause
There is a difference between on how Vista and WebReach execute a query of a data/waveform/event recorder. In WebReach there is timestamp filter. This filter will only return data for the specified range consequently the query runs fast. In Vista it will query the entire DB for that one meter; if the ION_Data database size is large the query may time out.

When a query runs in Vista the following error messages are displayed.

Image 1

Image 2


Resolution
In order to increase the timeout period of a Vista query, a new entry to the server's registry needs to be added such that the Query server connect timeout is increased.

*Warning: This article contains information about editing the registry. Improper changes to the registry can permanently damage the operating system. Always backup the registry before making any changes.*

Resolution A.  Increase the Vista query timeout

  1. Select Start > Run then type regedit in the Run window to open the registry
  2. Within the registry, navigate to the following path depending on your version of PME:
HKEY_LOCAL_MACHINE\SOFTWARE\Power Measurement\ION Enterprise\5.5
HKEY_LOCAL_MACHINE\SOFTWARE\Schneider Electric\ION Enterprise\5.6
HKEY_LOCAL_MACHINE\SOFTWARE\Schneider Electric\ION Enterprise\6.0
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\ION Enterprise\6.0
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\ION Enterprise\7.0.1
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\ION Enterprise\7.2.2
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\Power Monitoring Expert\8.0
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\Power Monitoring Expert\8.1
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\Power Monitoring Expert\8.2
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\Power Monitoring Expert\9.0
  1. Right click in the right hand pane and select New > DWORD Value
  2. Name the new DWORD: VistaQueryTimeout_s
  3. Right click on VistaQueryTimeout_s and select Modify
  4. Enter a new value for the timeout period.  The timeout period is 60s by default so its is recommendable to doubling its value to 120s (120 decimal) if this is not enough increase it to 180
  5. Select File > Exit to exit the registry editor

If the system include client machines running Vista this change need to be performed into the client's machine registry as well.

Resolution B.  Increase the Query server timeout

  1. Open the Query Server node in Designer.
  2. Open the properties for the Query module.
  3. Modify the Connect_Timeout from the default 60 to 120 (or 180 if it is necessary).
  4. Save this setting and restart the Query Server Service

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