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PME 8.x Installer fails at Retain Custom Data
Issue
The PME 8.0/8.1 upgrade installer fails in at the 'Retain Custom Data' step during the system configuration. The error returns the information: "Could not remove backup files (config_bak)".
Product Line
StruxureWare Power Monitoring Expert Base, Data Center Edition
Environment
Power Monitoring Expert 8, SQL Server 2008 R2/2010/2012/2014 Standard/Express
Cause
The installer fails at the Retain Custom Data step during the system configuration as it is not have the required write permissions to make necessary changes to the default Power Monitoring Expert directory folder. The permissions are likely to be set to "Read-only".
Resolution
Open the installer log and identify the directories with "Read-only" permission that are causing the error.
1. Change the folder permissions/attributes in order provide "Write" permissions to by unchecking the "Read-only" box for the following:
(1) the PME folder created for within Program Files (the default is the install location for ...\Schneider Electric\Power Monitoring Expert, and (2), for the current logged-in user's Temp folder. (To find the full path to the Temp folder, click Start >Run, enter %Temp% and click OK.) The default local system account is an example of an account with these privileges.
2. Ensure that the current user account and Administrators have 'Full Control' permissions set under the Security tab.
3. Ensure that the PME Installer/Configuration is run as an "administrator."
The PME 8.0/8.1 upgrade installer fails in at the 'Retain Custom Data' step during the system configuration. The error returns the information: "Could not remove backup files (config_bak)".
Product Line
StruxureWare Power Monitoring Expert Base, Data Center Edition
Environment
Power Monitoring Expert 8, SQL Server 2008 R2/2010/2012/2014 Standard/Express
Cause
The installer fails at the Retain Custom Data step during the system configuration as it is not have the required write permissions to make necessary changes to the default Power Monitoring Expert directory folder. The permissions are likely to be set to "Read-only".
Resolution
Open the installer log and identify the directories with "Read-only" permission that are causing the error.
1. Change the folder permissions/attributes in order provide "Write" permissions to by unchecking the "Read-only" box for the following:
(1) the PME folder created for within Program Files (the default is the install location for ...\Schneider Electric\Power Monitoring Expert, and (2), for the current logged-in user's Temp folder. (To find the full path to the Temp folder, click Start >Run, enter %Temp% and click OK.) The default local system account is an example of an account with these privileges.
2. Ensure that the current user account and Administrators have 'Full Control' permissions set under the Security tab.
3. Ensure that the PME Installer/Configuration is run as an "administrator."