En quoi pouvons-nous vous aider aujourd'hui ?

PME 8.x - "There was a problem processing your request." when trying to open a Data Log Viewer in Web Diagrams

Issue
A customer is attempting to open a Data Log Viewer through the Diagrams section of Web Applications.
picture of error

Product Line
Power Monitoring Expert 8.x

Environment
Web Applications - Diagrams

Cause
If the customer is using Internet Explorer as the web browser, it can default to no selected language in the request header of the web page. This will happen if the  HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\International registry key has a 'AcceptLanguage' value associated with it, and the data for that value is NULL.
If the 'AcceptLanguage' value does not exist at all, Diagrams will use the OS language, however if that value does exist, and it is empty, then Diagrams crashes.

Resolution
Configure the language settings within Internet Explorer.
Select Tools > Internet Options

internet options

Click 'Languages'. Within the Language Preference window, click 'Set Language Preferences'.

language prefrence

Select the default language configuration and apply the changes within Internet Options.
Close the browser and reopen to confirm the issue is resolved.

control panel language setting

The above changes can also be made with edits to the registry as outlined below

*Warning: This article contains information about editing the registry. Improper changes to the registry can permanently damage the operating system. Always backup the registry before making any changes.*

1) Navigate to HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\International registry key to check if key exist and the value of data.

registry edit
2) Insert correct data  - e.g. en-US, en; q=0.5
highlighting data

Schneider Electric Belgium

En savoir plus
Gamme :
En savoir plus
Gamme :

Besoin d'aide ?

Besoin d'aide ?

Sélectionnez le bon produit

Sélectionnez le bon produit

Trouvez rapidement et facilement les produits et accessoires adaptés à vos applications.

Obtenir un devis

Obtenir un devis

Effectuez une demande de renseignements en ligne et un expert vous contactera.

Où acheter ?

Où acheter ?

Trouvez facilement le distributeur Schneider Electric local le plus proche.

Centre d'aide

Centre d'aide

Trouvez des ressources de support pour tous vos besoins, en un seul endroit.

  • Documentation produits
  • Téléchargement de logiciels
  • Sélecteur de produits
  • Substitution et remplacement de produits
  • Centre d'aide et de contact
  • Trouver nos sites
  • Obtenir un devis
  • Où acheter
  • Communauté Schneider Electric
  • Carrières
  • Qui sommes-nous ?
  • Signaler une mauvaise conduite
  • Accessibilité
  • Salle de presse
  • Partenaires
  • EcoStruxure
  • Nos emplois
  • Blog
  • Soyez informé des nouveautés en premier ?
  • Protection des données
  • Mention sur les cookies
  • Conditions d utilisation
  • Conditions générales de vente et d'achat
  • Change your cookie settings