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Why does the IP address on my M580 / M340 not use the changed IP and revert back to the previous IP?

Issue:
I changed the IP address of the CPU or NOC module in my Control Expert / Unity Pro project.
Once the project is loaded and the CPU is in RUN, the changed IP does not take affect and it is reverting to the previous IP.
Why is this happening?

Product Line:
Quantum, M340, M580

Environment:
EcoStruxure Control Expert
Unity Pro

Cause:
After the IP address is changed in the CPU, NOC, NOE or any module that can use Ethernet, the configuration needs to be Validated.
If the Validation is not selected, Control Expert / Unity Pro is supposed to catch this before a build is performed and force the user to Validate the changes.
However, sometimes this does not happen and builds get created that did not go through the IP Validation.

Resolution:
While on the page of the IP configuration, select Edit > Validate or select the Checkbox Icon on the menu bar.
It is usually located below the PLC menu heading, but could be in another location depending on your screen resolution.
If the choice for Validate is not selectable, you would just need to make a new change to the IP configuration and apply them to make the Validate button usable.

Note:
As a precaution before you build, you should open the Tools > Ethernet Network Manager. This tool will show the configuration that gets loaded into the PLC.
If this configuration does not match the changes that were made to the IP address, then a Validation is necessary.

If this FAQ did not solve your issue, you can chat with us at chat with us or e-mail us at customer.services@se.com to create a case with our Technical Support Team.

If you are not located in North America, please contact your local Customer Care Center for assistance:

Support | Schneider Electric Global (se.com)

Schneider Electric Belgium

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