Issue
Unable to change the date and time of a PM820 meter.
Product
PM820 - Series 800 Power Meter
Environment
PM820
Firmware Version 10.310
Cause
This problem has been identified only on a PM820 with firmware version 10.310.
Resolution
There are 2 possible solutions.
First solution: Upgrade the firmware to version 10.410 or greater.
Access to firmware upgrade instructions can be found here, and a how-to video and a link to the latest firmware
can be found at: How to upgrade firmware on a PM800 series meter from version OS 10.060 or below to the latest version | Schneider Electric USA
Additionally, supporting documents and file downloads on this and a wide variety of other products and topics may be obtained
using the search function found at the: Download Center
Second solution: apply the following procedure:
To change the time, you have to:
1) change "HOUR"
2) press "OK"
3) change "MIN"
4) press "OK"
5) change "SEC"
6) press "OK"
7) change desired time format (24H or AM/PM)
8) DO NOT press "OK"; instead press UP ARROW button (left softkey)
NOTE: If format was changed then UP ARROW again and you will be prompted to save; Else you're done.
To change the date, you have to:
1) change "MONTH"
2) press "OK"
3) change "DAY"
4) press "OK"
5) change "YEAR"
6) press "OK"
7) change desired date format
8) DO NOT press "OK"; instead press UP ARROW button (left softkey)
NOTE: If format was changed then UP ARROW again and you will be prompted to save; Else you're done.
Released for: Schneider Electric Egypt and North East Africa


Need help?
Product Selector
Quickly and easily find the right products and accessories for your applications.
Get a Quote
Start your sales enquiry online and an expert will connect with you.
Where to buy?
Easily find the nearest Schneider Electric distributor in your location.
Help Center
Find support resources for all your needs, in one place.