Issue:
Would like to increase the PowerChute Network Shutdown license quantity.
Product:
PowerChute Network Shutdown
Environment:
Any system running an instance of licensed PowerChute Network Shutdown.
Cause:
Added a node/server that requires licensing.
Solution:
NEW in mySchneider: Increase Quantity per License in Digital Locker
Beginning Oct 14th, 2024, PowerChute customers will have the ability to increase the Quantity of Nodes on a License
[Activation ID] from within mySchneider Software Experience Digital Locker.
How to Increase Quantity of Nodes on a License:
- Identify the License [Activation ID] you wish to increase Quantity from the PowerChute application user interface.
- Log in to mySchneider and click on "Software" in the top navigation to arrive at mySchneider Software Experience.
- Under the "Licenses" tab, you will see the list of licenses [Activation IDs] available to manage.
- For the License [Activation ID] you wish to add Nodes to, click the "Actions" option on the right side of the listing.
- Select "Increase Quantity" option.
- A dialog box will appear where you may update the quantity for the License [Activation ID]
- Click "Increase Quantity" button to finalize and apply the Credits to the additional nodes.
FAQs:
- What does the Quantity of Nodes represent?
The quantity refers to the count of servers within a single license setup. - How quickly will the new Nodes be available for use in the application after adding them in mySchneider?
We recommend a service restart in the software application to refresh the latest license information.
- What is a Credit?
A Credit represents one unit of a product for its full term. - I want to increase my Quantity a few months after my initial purchase - how will my Credits be used?
The required credits will be calculated and pro-rated for the remaining term period, matching the updated quantity.
- Why are the "Update Quantity" toggle and "Increase Quantity" button disabled when I try to add Nodes?
The MSE User must have available credits for the selected SKU in order to increase the quantity on their license.
Released for: Schneider Electric Egypt and North East Africa


Need help?
Start here!
Find answers now. Search for a solution on your own, or connect with one of our experts.
Contact Support
Reach out to our customer care team to receive more information, technical support, assistance with complaints and more.
Where to buy?
Easily find the nearest Schneider Electric distributor in your location.
Search FAQs
Search topic-related frequently asked questions to find answers you need.
Contact Sales
Start your sales inquiry online and an expert will connect with you.