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Power Monitoring Expert (PME) - Secondary server installation fails on "Configure Network Settings" step.

Published date: 17 February 2020

Issue
The PME installer fails on the Configure Network Settings step with an error message indicating:
A connection could not be established to the Database server. Ensure the server is running and accepting connections.

Product Line
Power Monitoring Expert 9.0
Power Monitoring Expert 8.x
Power Monitoring Expert 7.2.x

Environment
PME Secondary Server, Installer

Cause
The secondary server is unable to connect to the database instance. 

Resolution
To verify that the secondary server cannot connect to the database instance, attempt saving a UDL file on the desktop. If the file cannot be saved, an error will appear indicating that a connection to the SQL Server failed. 
Attempting to test a database connection using a UDL file prompts the error “SQL does not exist or access denied”. This clearly indicates that the secondary machine cannot connect to the database instance.

 
Once verified that this is the issue, follow the steps below to resolve the connection issues.
  1. On the Database server, typeSQL Server Configuration Manager in the windows start menu and open the application.
  2. Expand SQL Server Network Configuration and select Protocols for ION.
  3. Click on the Named Pipes Protocol Name and change the status to Enabled.
  4.  Restart the SQL server service for the changes to take effect.

If the issue still exists, make sure that hat the SQL server accepts remote connections. Please refer to the link below for assistance with configuring SQL for remote connections.
Additionally, if a firewall is used on the Primary / Database / Secondary server then certain ports will need to be included in the exception list for opening. PME port requirements can be found on page 51 of the PME System Guide
 

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