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Ethernet support is not getting updated in management console post re-installation of custom device type
Issue Description:
After re-installing the custom device type, the device template has not been updated to Ethernet Support. In management console, device will still be in the list of devices with only RTU support.

Product Line:
Power Monitoring Expert 2022

Environment:
Power Monitoring Expert- Custom device type

Cause:
In ION Database table the ethernet support value is not changing to 1, post re-installation of custom device type.

Resolution:
Warning: “This article contains information about editing the database. Please note, editing or updating anything in DB may cause permanent damage and result in PME to function improperly. This procedure should only be performed by users familiar with SQL Server Management Studio. Kindly take a backup of the database before performing any such action."

Users need to manually change EthernetSupport from 0 to 1 in the device type table under ION_Network database. After changing the value, in management console custom device type will appear in the list of devices with Ethernet support.

To achieve this, follow the below steps,
  1. Connect to the ION Database Via SSMS.
  2. Go to ION_Network --> Select Tables
  3. dbo.Device type --> Right click and select Edit top 200 rows
  4. Under Ethernet support column, change the value from 0 to 1 for the created custom device type.
  5. Close the SSMS
Now the custom device type will appear in the list of Ethernet devices in Management console.

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