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NetBotz 300-500 Series | External Storage Configuration
Issue:
Setting up external storage on a 300-500 series NetBotz Appliance

Product Line:
NetBotz 300-500 Series (355, 455, 450, 550, 570)

Environment:
NetBotz 300-500 Series (all versions)

Cause:
Need to expand storage capacity for NetBotz 300-500 series appliance.

Resolution:

Using Windows Network Share for External Storage
  1. Click the External Storage icon to open the External Storage window.
  2. Click Add... to open the External Storage Configuration window.
  3. Select Windows Share and click Next.
  4. Enter the configuration information.
  5. Click Next.
  6. In the Select Action window, choose:
    • Use network external storage when the Windows share has already been used by this appliance and you have chosen to un-share this mount.
    • Initialize (clear existing appliance data) and use network external storage the first time you use the Windows share with this appliance or if the Windows share was used with another appliance.
  7. Click Finish. A prompt to reboot the appliance appears.
  8. Click Reboot. The appliance automatically reboots. This may take a few minutes during which the Advanced View will be unavailable.
Note: If you change the mount point or share for your External Storage System, be sure to follow the Removing External Storage before adding your new storage.
Using NFS for External Storage
  1. Click the External Storage icon to open the External Storage window.
  2. Click Add... to open the External Storage Configuration window.
  3. Select NFS Mount and click Next.
  4. Enter the configuration information.
  5. Click Next.
  6. In the Select Action window, choose:
    • Use network external storage when the NFS mount has already been used by this appliance and you have chosen to un-share this mount.
    • Initialize (clear existing appliance data) and use network external storage the first time you use the NFS mount with this appliance or if the NFS mount was used with another appliance.
  7. Click Finish. A prompt to reboot the appliance appears.
  8. Click Reboot. The appliance automatically reboots. This may take a few minutes during which the Advanced View will be unavailable.
Note: If you change the mount point or share for your External Storage System, be sure to follow the Removing External Storage before adding your new storage.
Using USB Thumb Drive for External Storage

NOTE: You cannot select the USB Drive option if no USB drive is connected to your appliance.
NOTE: Only the 400-500 series appliances have the option for USB External Storage.
  1. Click the External Storage icon to open the External Storage window.
  2. Click Add... to open the External Storage Configuration window.
  3. Select USB Drive and click Next.
  4. The Select Operation pane appears and displays the following selections:
    • Use External Storage: Configure the appliance to use the External Storage System without formatting the file system first. This option is used if the External Storage System connected to your appliance is formatted and contains camera and sensor data.
    • Format and use External Storage: Formats the External Storage System file system and configures the appliance to use the External Storage System.
  5. Select an operation and click OK.
    • If you select Use External Storage, a confirmation message advises you that the appliance must restart to complete the task. Click Finish to restart the appliance. When the restart is complete, all External Storage System functionality is available.
    • If you select Format and use External Storage, a confirmation message advises you that formatting the extended storage device will destroy any data stored on the device and that formatting can take ten or more minutes to complete, after which the appliance must restart. Click Finish. Once the External Storage System is formatted, your appliance restarts. When the restart is complete, all External Storage functionality is available.
Note: If you change the mount point or share for your External Storage System, be sure to follow the Removing External Storage before adding your new storage.
Removing External Storage
  1. Double-click the External Storage icon. Then click Stop Using. A confirmation message notifies you that this action will cause the appliance to reboot.
  2. Click Stop Using. A prompt to reboot the appliance appears.
  3. Click Reboot. The appliance automatically reboots. This may take a few minutes, during which time Advanced View ill be unavailable.
  4. If you are removing an External Storage System, turn off the power to your appliance.  Unplug the External Storage System from the appliance, and then restore power to your appliance.

Reclaiming External Storage Data

External Storage data is stored in a top-level directory on the remote server. The data is stored in a directory that is named using the MAC address of the appliance.

For example, if your External Storage target NAS is \\Server1\storage, you specify a subdirectory of Headquarters, and if the appliance MAC address is 00:02:D3:02:9F:50, the data is stored at:
\\Server1\storage\Headquarters\00_02_D3_02_9F_50.

If you need to replace an appliance, copy all of the data that is stored in the old directory into the new directory.

For example, if the MAC address of the new appliance is 00:02:D2:02:9F:51, you would copy the data stored in \\Server1\storage\Headquarters\00_02_D3_02_9F_50 to \\Server1\storage\Headquarters\00_02_D3_02_9F_51.

Once the data is moved to the new directory, use the External Storage task to configure the same driver settings as you had configured on the previous appliance and select Use/Claim selection.

Doing this should provide access to all data that was gathered by the previous appliance.

NOTE: Do not initialize the target share.

Schneider Electric Ireland

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