PME - Trends not loading real-time data with error "Cannot retrieve any data"
Issue
In the PME Web Applications, real-time data doesn't load in Trends. Clicking on the flashing exclamation point icon shows "Cannot retrieve any data. Ensure that all required services are running on the server."
Product Line
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024
Environment
Web Applications
Trends
Internet Information Services (IIS)
Cause 1
A required ION service isn't running.
Resolution 1
1. Open the Windows Start Menu, then search for and open Services.
2. Check that all services starting with the word "ION" that also have a Startup Type of "Automatic" or "Automatic (Delayed)" are Running. If any are stopped, start them.
Cause 2
Various configuration errors with the Web.config files used for the PME web server can cause this problem. The below steps show how to resolve one possible configuration error as an example.
Resolution 2
*Warning: Take backups of any files prior to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).
1. In the Web Applications, navigate to the Settings tab > System > System Log.
- Note: If on PME 9.0, refer to the steps at this article for how to use the Diagnostics Tool: https://www.se.com/us/en/faqs/FA275753/
- To output this log using the Diagnostics Tool, select only the "AppMods Diagnostics" output and uncheck "Compress package". Then, you can view the log by opening the AppMods Diagnostics.html file in the Outputs folder of the generated diagnostic.
2. Use the Minimum Priority dropdown to filter for "Error", then look for an error that mentions a URL for one of PME's web components. Note the web component shown after the server name in the URL, for example http://localhost/WebServices/WebRealTime.svc indicates the problem is with the WebServices page:
3. Open the Windows Start Menu, then search for and open Internet Information Services (IIS).
4. Expand the server name > Sites > Default Web Site, then select the page mentioned in the error message. Double-click on Error Pages:
5. Click Edit Feature Settings..., select Detailed Errors then click OK:
6. Select the page in the left pane again, then click Browse *:443 (https)
7. The web page opens displaying a configuration error. Note the Error Message, Source Error, and Source File to determine which Web.config file and what the issue is. In the following example, it shows:
- Error Message: "A child element named 'service' with same key already exists at the same configuration scope. Collection elements must be unique within the same configuration scope (e.g. the same application.config file). Duplicate key value: 'PowerQuality.Analytics'."
- Source Error: (location of the issue in the file)
- Source File: C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\system\WebServices\web.config
8. Open File Explorer, then navigate to the location of the Web.config file. In this example it's C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\system\WebServices\web.config
9. Open the Web.config file in Notepad:
10. Refer to the Source Error on the web page and navigate to the same location in the Web.config file, then refer back to the Error Message to identify the configuration issue. In this example, the error mentioned Duplicate key value: 'PowerQuality.Analytics', so to resolve this error, delete the duplicate section for 'PowerQuality.Analytics':
11. Go to File > Save As, then save onto the Desktop since the folder won't allow overwriting the file directly:
12. Move the saved file into the location of the original Web.config file to overwrite it:
13. Open the Windows Start Menu, then search for Command Prompt. Right-click on Command Prompt > Run as Administrator
14. Run the following command: iisreset
15. Open Services and restart the ION Application Modules Core Services Host service. Click Yes when asked to restart the ION Application Modules services.
16. Close and reopen the web browser.
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