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Why does my M241 PLC's IP Address always revert back to 10.10.x.y when I use the TM4ES4 module?

Issue

Why does my M241's IP Address always revert back to the factory default 10.10.x.y where x and y are the last two octets of the MAC Address for the Ethernet port when I use the TM4ES4 module?

Product Line

Modicon M241 PLCs with Ethernet

TM4ES4 network switch module

Environment

Networking of Physical Programmable Logic Controllers

Cause

The most common cause of this occurring is when the IP Address of both the Ethernet_1 port of the M241 and the IP Address of the TM4ES4 are both set to the same subnet address.

The Ethernet ports on the M241, M251, and M262 PLCs have a validation rule that does not allow them to be on the same Subnetwork.

If the firmware detects this, it will revert the IP Addresses of both Ethernet_1 and the TM4ES4 to their default IP Addresses based on their MAC Addresses.

Resolution

Steps:

1) Disconnect the Ethernet cables from the PLC

2) Connect a USB cable between your laptop running EcoStruxure Machine Expert and the PLC

3) Login to the PLC

4) In the Device Tree, double-click on Ethernet_1

5) Change the IP Address so that it is not in the same Subnet range as the TM4ES4

6) In the Devices Tree, expand COM_Bus with the [+] button, and Double-click on the TM4ES4 node

7) Ensure that the Subnet of the TM4ES4 is not the same as the Ethernet_1

8) Login via (USB cable) and Download the changes

9) Go to the dropdown menu Build > Post Configuration… > Edit… (If this is greyed-out, then skip steps 10 and 12)

10) In the editing box that appears, if you see a line showing "# TM241CE***** / Ethernet_1 / IPAddress"

- 2 lines beneath it, change the IP Address to the same as what you entered in Step 5.

11) Save the changes.

12) Power cycle the PLC

13) Plug in the Ethernet cables

Result: The PLC will now have Ethernet_1 and the TM4ES4 assigned to two unique subnets.

If this article does not answer your question, check out our FAQ database that has answers to more commonly asked questions:

Frequently Asked Questions - Schneider Electric (se.com)

If this FAQ did not solve your issue, you can chat with us at chat with us or e-mail us at customer.services@se.com to create a case with our Technical Support Team.

If you are not located in North America, please contact your local Customer Care Center for assistance:

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