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PME - Utility customer's 8650 Data Recorder (0xF8A) not downloading data
Issue
The 8650 meters the data recorder (0xF8A) SagSwellState sometimes gets into a state where it does not download any data and gets stuck at around 3000 records.

Product Line
Power Monitoring Expert 8.x
Power Monitoring Expert 9.x

Environment
ION 8650 meter framework

Cause
The 8650 meters the data recorder (0xF8A) SagSwellState sometimes gets into a state where it does not download any data and gets stuck at around 3000 records. In some cases, this problem can also cause the meter not to respond to requests for real time data.

Resolution
The 8650 meters the data recorder (0xF8A) SagSwellState sometimes gets into a state where it does not download any data and gets stuck at around 3000 records.
This can also cause other problems as LogInserter will keep trying to get information from this meter and potentially slow down or stop the downloading of records from the meter while it is trying to deal with this one Data recorder.

Summary of Issue
The problem is when the Data Recorder gets a lot of data in a short period of time.
  • Normal set Data Recorders have a buffer of 100 records that they then write to Meter’s File system.
  • For Fast incoming data if the buffer gets overloaded, then it writes to the meter that it has a record for that Position counter, but doesn’t get a chance to write the value.
  • This means when a lot of data comes into a data recorder in a short amount of time, the meter thinks writes in the file system it has data for a Timestamp/Positioncounter when it does not.
  • When LogInserter requests data at a later time, the meter has to go through all of the Partial data records (the ones with no values) one by one until it finds ones with data in them.
  • This causes a slowdown as a normal request to a data recorder do not have partial records without values.  The more partial values a data recorder has to go through, the longer it takes to return the request and eventually this causes a timeout in loginserter.
  • Once it reaches a level where it times out, the data recorder never recovers because it never gives back a response for the Loginserter to update the position counter.

Work Around
Work around is to change the data recorder’s Log Mode to be high speed continuous.  This means that the buffer size will match whatever size the depth of the meter has and will not write partial records.
WARNING: Changing this setting will purge all the current records in the data recorder.

If the customer wants the current data in the data recorders they can try the following.  If they are ok with losing the current data in the SagSwellState recorder then they can skip these steps.
  1. Change the devices Receive Timeout (management console -> configure Device -> Device Advanced Properties -> Receive Timeout -> change to 60000 ms)
  2. Disable the other meters if possible and wait to see if the records start coming in.  This will most likely be a slow process.
  3. Once the records have been downloaded Make the change to the Data recorder and set the Receive timeout back to 10000.(Or its original value)

Updating the Data recorder to High Speed Continuous
  1. Open the meter in Designer and go to the SagSwellState Data Recorder
  2. Right click on SagSwellState Data recorder
  3. Change the “LogMode” to be “High Speed Continuous”
  4. It will prompt you to confirm as this will delete the existing data in the SagSwellstate Data Recorder.
  5. Save the changes and close designer.

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