Issue:
When trying to log in to Web Applications in Power Monitoring Expert 8.1, the login fails, and a dialog appears at the bottom of the browser window.
Do you want to open or save AUTH?ReturnUrl=%2fweb (108 bytes) from Localhost?
Product Line:
Power Monitoring Expert 8.1
Environment:
Web Applications
Cause:
Cause 1
This can happen if IPv6 is enabled. To determine if IPv6 is enabled, in a cmd prompt, type ping <machine name>. If you get back an IPv6 address, then IPv6 is enabled (see image below):
Cause 2
The DataSourceSignature value does not match between the ApplicationModules database and the DataServiceHost.config file.
Cause 3
The ApplicationModules database has not been upgraded properly.
Cause 4
The ApplicationModules services are not started.
Resolution:
Resolution 1
Attached to this article is a hotfix that should correct this problem. See the attached ReadMe for deployment instructions.
Note: This hotfix applies to Power Monitoring Expert 8.1 only.
Resolution 2
*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*
*Warning: Take backups of any files prior to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).
To check/fix the value:
Resolution 3
Running a configure from the PME 8.1 Installation disc will re-run the upgrade scripts.
Resolution 4
Start the ApplicationModules services: ApplicationModules CoreServicesHost, ApplicationModules DataServicesHost, and ApplicationModules ProviderEngineHost.
When trying to log in to Web Applications in Power Monitoring Expert 8.1, the login fails, and a dialog appears at the bottom of the browser window.
Do you want to open or save AUTH?ReturnUrl=%2fweb (108 bytes) from Localhost?
Product Line:
Power Monitoring Expert 8.1
Environment:
Web Applications
Cause:
Cause 1
This can happen if IPv6 is enabled. To determine if IPv6 is enabled, in a cmd prompt, type ping <machine name>. If you get back an IPv6 address, then IPv6 is enabled (see image below):
Cause 2
The DataSourceSignature value does not match between the ApplicationModules database and the DataServiceHost.config file.
Cause 3
The ApplicationModules database has not been upgraded properly.
Cause 4
The ApplicationModules services are not started.
Resolution:
Resolution 1
Attached to this article is a hotfix that should correct this problem. See the attached ReadMe for deployment instructions.
Note: This hotfix applies to Power Monitoring Expert 8.1 only.
Resolution 2
*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*
*Warning: Take backups of any files prior to modifying them. Ensure the backups are in a location that will not be overwritten (i.e. the Desktop).
To check/fix the value:
- Open SQL Server Management Studio
- Query the DataSourceBus.DataSource table in the ApplicationModules database. There should be one row in this table that has a GUID value in the Signature column.
- Note the value from the Signature column. You might need it in the following steps.
- Locate the DataServicesHost.config file (by default it is in the following directory "C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\Applications\bin\DataServicesHost.config")
- Create a backup copy of this file
- Open the file with Notepad and look for the line where the "key" is equal to DataSourceSignature
Example: <add key="DataSourceSignature" value="ee0942eb-5bf2-45ce-864c-620973341cca" />
Note: The "value" for DataSourceSignature is different for every system, and it will change between each installation of PME. If the DataSourceSignature "value" is different than what you found in the database, you must change it to match.
Note: The "value" for DataSourceSignature is different for every system, and it will change between each installation of PME. If the DataSourceSignature "value" is different than what you found in the database, you must change it to match.
- Stop the ApplicationModules services.
- Edit DataServicesHost.config so that the "value" for the DataSourceSignature key is the same as what's in the database
- Restart the ApplicationModules services
Resolution 3
Running a configure from the PME 8.1 Installation disc will re-run the upgrade scripts.
Resolution 4
Start the ApplicationModules services: ApplicationModules CoreServicesHost, ApplicationModules DataServicesHost, and ApplicationModules ProviderEngineHost.