Issue.
In Vista, when a User open a diagram that includes real time objects linked to Advanced Security enabled meters, User is prompted for meter login. If an incorrect password is entered, then the error dialog will pop up indicated that the user has insufficient privilege to access the meter. If the User tries again and this time enter the correct credentials still cannot access the meter.
Product Line
Power Monitoring Expert 8.2
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024
ION9000/8650/7650 Series Meters
PM8000 Series Meters
Environment
A PME system that includes Advanced Security enabled meters.
Cause
When a user enters credentials for Advanced Security enabled meters, they get saved to that user's workspace file in encrypted form. For example, if the user logs into Vista as supervisor, the workspace file will be called supervisor.wsu.
The wsu files can be found in ...\Power Monitoring Expert\config\cfg\ud directory.
Some workflows will result in incorrect credentials being written to that file which results in the behaviour described above. Unfortunately, it has not been determined exactly what workflows will cause this problem.
Resolution
At present, the only known workaround is to delete the wsu file for that user. This will mean that passwords will need to be re-entered when accessing Advanced Security enabled meters.
Recommendation:
If you are using an older version of PME, consider upgrading to the latest version for improved protocol support and security. For assistance with integration or upgrades, contact Schneider Electric Technical Support at: pmo-psup@se.com