{}

Our Brands

Impact-Company-Logo-English Black-01-177x54

Welcome to the Schneider Electric Website

Welcome to our website.
How can we help you today?
How do I setup my ATV630, ATV930 and ATV340 drives to connect to Somove using Ethernet?

Issue:
How do I set up Somove over Ethernet on the Process Drives?

Product Line:
Altivar 630 and 930 Process Drives
Altivar 340 Machine Drives

Cause:
Customer needs to program/control the drive over a network

Resolution:
Step 1
Need to find your PC’s Ethernet IP addressing information:
In your Windows search box (in the Start menu if using Windows 7)
Type ‘cmd’ enter - Command Prompt window opens
Type ‘ipconfig’ and press Enter
Note the IP address, Subnet Mask, and Default Gateway of your PC

Step 2
Power up the ATV drive
Using the HMI (keypad), from the main menu, go to the menu 6 Communication and press OK
Highlight "Comm parameters" and press OK
Scroll down and highlight "Embd Eth Config" and press OK (if using an Ethernet option card go to "Eth Module Config")
Set IP Mode Ether. Embd to ‘Fixed’
IP address needs to be the same as your PC except change the last octet to another number not already being used by another machine on your network (ex: your PC= 192.168.1.2 and the drive= 192.168.1.6)
Set the ‘Mask’ to match your PC’s Subnet Mask (ex: 255.255.255.0)
Set the ‘Gateway’ to match your PC’s Default Gateway (ex: 192.168.1.1)
Power off the drive completely and then reapply power (network settings are only implemented during the power up stage of the drive).

Step 3
Open your SoMove software
On the left-hand side of the SoMove window click “Edit Connection / Scan”.
At the top left of the Scan Result window click “Modbus TCP”
At the top right of the Scan Result window click the Advanced Settings button, which looks like a gear
Choose the Scan tab at the top of the Advanced Settings window
Enter your Drive’s IP address leaving the last octet as 0 and enter the last octet digit in the single scan box.
Example: 192. 168.1.0
Scan configuration: Single (checked) = 6
Click Apply and click OK. (You may have to scroll down and to the right to see these)
In the Scan Result window click “Scan Network” in the lower-left-hand corner to scan for the drive
Once your drive is discovered, double-click on it to begin working with it

NOTE: SoMove and the ATV630, 930 and 340 drives also support IPV6 addressing....so if your PC is configured to allow IPV6 networking then there is no need to set the IP address on the drive.  Simply select ModBus IPV6 in the Edit Connection /Scan dialog box and SoMove should automatically discover any compatible drives on the network.   Note that some IT departments disable IPV6 and it can be blocked by some anti virus software so if this does not work, contact your IT department or follow the steps above to use IPV4 addressing.

If this article does not answer your question, check out our FAQ database that has answers to more commonly asked questions: Frequently Asked Questions - Schneider Electric (se.com)

If this FAQ did not solve your issue, you can call us at 1-888-778-2733 Option 2 and then 4 or e-mail us at drive.products.support@se.com to create a case with our Technical Support Team.

If you are not located in North America, please contact your local Customer Care Center for assistance: Support | Schneider Electric Global (se.com)

Schneider Electric Australia

Explore more
Range:
Articles that might be helpful Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.
Explore more
Range: