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NetBotz | How to update the Self-signed Certificate?
Issue:
How to update the Self-signed Certificate on NetBotz appliance?

Product Line:
NetBotz 355,450,455,570

Environment:
NetBotz (All Versions)

Cause:
The SSL Certificate needs to updated on the appliance

Resolution:

To update the SSL certificate follow the instructions below:

1. Be sure the appliance is registered with DNS and you can ping it by Fully Qualified Domain Name (FQDN). i.e. "ping netbotz.example.com"

2. Enable Telnet on the NetBotz appliance by using the following URL: http://botname/enabletelnet
Notes: a. Use HTTPS in the URL if HTTP is disabled. b. Replace 'botname' in the URL with the FQDN or IP address of your NetBotz Appliance.

3. Telnet to the NetBotz appliance using Windows Command Prompt, PuTTy, or any other Telnet client.
Username/password on v3.X.X or 4.X.X firmware is root/apc
Username/password on v2.X.X firmware is root/netbotz

4. Press Shift+X within 5 seconds after logging in to break to a command line interface where the next steps must be completed.

5. From the command line, run the following commands:
cd /opt/netbotz/bin
source ssl-cert-functions
update_nbSelfSignedCert

6. Reboot the appliance via Advanced View by going to Tools > Reboot Appliance.

Alternately, changing the hostname and rebooting the appliance will renew the self signed certificate. If desired it can be changed back and rebooted again.

Schneider Electric Australia

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