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Power Monitoring Expert - Cannot locate a DataSource for the Signature

Issue:
When trying to do tasks within the Power Monitoring Expert Web Applications, some of the functionality may be hampered due to misconfiguration with the configuration files. These would need to be resolved to ensure full system functionality.

Product Line:
Power Monitoring Expert (PME) 2021
Power Monitoring Expert (PME) 2022
Power Monitoring Expert (PME) 2023
Power Monitoring Expert (PME) 2024

Environment:
Power Monitoring Expert Application Server

Cause:

  • The diagrams tab does not open and presents message: Source Measurement list did not load. There was an error attempting to load the Source Measurement list from the server. The application is usable, but no selections can be added or edited. If this problem persists, contact your system administrator.

source measurement did not load

  • Trends do not load real-time data and say, "Waiting for Initial Data". In the event log, there is the message "Unable to fetch Real Time data. No data returned."

  • System log gives message "Cannot locate a DataSource for the Signature: ...."

real time data

  • When trying to run certain reports it will complete but show no data. In the system log, it will show the message: "System.ServiceModel.FaultException'1[Framework.Interfaces.Faults.SystemFault]: The data source is not initialized. Please wait and try again later. (Fault Detail is equal to Framework.Interfaces.Faults.SystemFault)."


Post upgrade, there may be some discrepancies between the config files, or not all the information may transfer over properly. In this case the signature used to map the application modules' services to the database did not copy over. This signature can be found by running the following query:

Use ApplicationModules
Select * From DataSourceBus.DataSource

The signature will be found in the "Signature" column. It will be unique to each system and should not be distributed.

Resolution:

*Warning: Irreparable database and application damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure. Backup any configuration files as well.*

  1. Copy the correct data source signature from DataSourceBus.DataSource in the Application Modules database.
  2. Stop the services that start with "ION Application Modules ...".
  3. Update both Dataservicehost.config files with the correct signature from the database. These files can be found in when navigating to the Power Monitoring Expert root folder, typically found in the path C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\Applications\bin or C:\Program Files (x86)\Schneider Electric\Power Monitoring Expert\Applications\binx64. This path may differ slightly depending on the installation path.
  4. Restart the services that start with "ION Application Modules ...".
  5. Reload the Power Monitoring Expert Web Applications page to ensure that the changes took effect and were successful.

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