Running Designer on a client machine reports an error when trying to open a node diagram
Issue
Opening a meter node template in Designer on a newly installed client machine reports the following error "The directory for node diagram could not be created"
Product Line
ION Enterprise 5.x
ION Enterprise 6.x
Power Monitoring Expert 7.x
Power Monitoring Expert 8.x
Power Monitoring Expert 9.0
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024
Environment
Engineering Client
Designer
Cause
1) The sharing permissions of the ION_Ent share folder are not set properly on the primary server
2) The client machine's Root2 registry key is not pointing to the config folder on the primary server
Resolution
To set the File Share permissions please follow the below steps:
- On the primary Ion Enterprise/PME machine navigate to the folder Ion Enterprise/Power Monitoring Expert folder. The paths are as below:
For Ion Enterprise 5.x/6.x machines : ...\Program Files\Schneider Electric\
For PME7.x and newer : ...\Program Files (x86)\Schneider Electric\ - Right click on Ion Enterprise/Power Monitoring Expert folder and go to properties and then click on tab labeled "Sharing"
- Click on "Advanced Sharing" which will open a new window. Click on permissions
- In the share Permissions tab, select Everyone on the top and provide permission to "change" by checking the box to Allow.
NOTE:
All share permissions are automatically set to the Read permission for the Everyone group; this includes the ION Enterprise share (ION_Ent).
A user must configure the ION_Ent share to the Change permission only if installing Secondary Servers on the network or if installing Clients
that require more than just Read permissions (e.g., A client user need to Modify Vista diagrams, update device templates etc)
Follow the steps below to check the value of the Root2 registry key on the client machine and ensure it is pointing to the config folder on the application server:
** Warning - Making registry changes can render the operating system inoperable. Please ensure the proper backups are taken before making any changes **
- On the client machine type 'regedit' into the Windows start menu search.
- Right click on 'Computer', select the Export option, and save this file in a secure location. This will create a full back up of the registry in case any changes need to be reverted.
- Browse to the registry directory below depending on the software version installed.
PME 7.2 and newer - Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\Power Monitoring Expert\(version number)
PME 7.0.1 and older - Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\ION Enterprise\(version number)
For example, the full registry path for a PME 8.1 system would be:
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\Power Monitoring Expert\8.1
while an ION Enterprise 6.0 system would be:
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Schneider Electric\ION Enterprise\6.0 - Within the numbered directory locate the 'Root2' registry key. On a client machine this path will point to the primary server's config folder. (example: \\PMESERVER\ION-Ent\config). On the server itself the path will display the local config directory as seen in the screen shot below.
- Update the path in the Value data field after double clicking the 'Root2' registry key.
Udgivet til: Schneider Electric Danmark


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