ENM 8.3 does not load tags from Power Monitoring Expert, 'Utility.UpdateEfSourcesException' in the diagnostic page
Issue
After configuring ENM to connect to Power Monitoring Expert (PME), ENM is able to observe events coming from PME however no tags are loaded. Diagnostic log contains the following error:
"An exception of type 'Utility.UpdateEfSourcesException' occurred and was caught."
Product
ENM 8.3 with PME 8.X
Environment
Internet Explorer
Cause
A SQL stored procedure has a variable defined as text rather than nvarchar
Resolution
*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*
1) Open SQL Server Management Studio (SSMS) and connect to the instance where the ENM databases are located
2) In the object explorer, expand the databases-> PLES_APM -> Programmability -> Stored Procedures
3) Locate [PLES_APM].[dbo].[usp_MM_xml_UpdateNodeSet] and right click on the procedure -> Tasks -> ALTER to -> New Query Editor Window
4) Search for "@Data text" (without quotes) and replace with "@Data nvarchar(max)" (without quotes)
5) Execute the statement
6) Repeat steps 3 through 5 for the stored procedure [PLES_APM].[dbo].[usp_xml_UpdateNodeSet]
Udgivet til: Schneider Electric Danmark








Brug for hjælp?
Produktvælger
Find hurtigt og nemt de rette produkter og det rette tilbehør til dine anvendelser.
Få et tilbud
Start din salgsforespørgsel online, så vil du blive kontaktet af en ekspert.
Find forhandler
Find den nærmeste Schneider Electric-distributør.
Hjælpecenter
Find supportressourcer til alle dine behov på ét sted.