Issue
If the Power Monitoring Expert (PME) Data Export Report is opened in Excel, and Chinese characters have been used such that they appear in the column headings, Excel will not display them correctly. This is an Excel issue, not a PME issue.
Product Line
Power Monitoring Expert 7.2
Power Monitoring Expert 8.x
Power Monitoring Expert 9.x
Power Monitoring Expert 2020
Power Monitoring Expert 2021
Power Monitoring Expert 2022
Power Monitoring Expert 2023
Power Monitoring Expert 2024
Environment
Viewing the Data Export Report in Excel if Chinese characters are used in device names or custom measurement names.
Cause
Ths problem occurs because the Data Export Report is saved in CSV format, and by default, Excel reads CSV files as non-unicode.
PME correctly exports the file as unicode (UTF-8), however if opened in Excel directly, Excel reads the file as non-unicode.
Resolution
How To Open a Unicode CSV in Excel (the right way)
This issue occurs because we scrape the data as unicode text, but Excel reads CSV files in non-unicode by default.
To configure Excel to use unicode on your exported CSV reports:
- Start Microsoft Excel
- In Excel, click the Data tab, and in the Get External Data ribbon/panel, click From Text .
- In the Import Text File dialog box, in the lower-right corner (to the right of the File name box), select Text Files (*.prn;*.txt;*.csv) as the file type, browse to the location where you exported/downloaded the CSV file, and then click Open (or Import).
- In the Text Import Wizard - Step 1 of 3 dialog box, select Delimited, and from the File origin drop-down list, select 65001: Unicode (UTF-8) (or the appropriate language character identifier for your particular environment).
In the Preview box, make sure that your unicode text displays properly, and then click Next. - In the Text Import Wizard - Step 2 of 3 dialog box, in the Delimiters section, make sure that only Comma is checked, and then click Finish.
- In the Import Data dialog box, select New worksheet (or Existing worksheet if you have one), and then click OK.
Recommendation:
If you are using an older version of PME, consider upgrading to the latest version for improved protocol support and security. For assistance with integration or upgrades, contact Schneider Electric Technical Support at: pmo-psup@se.com